Page MenuHomePhabricator

Plans: 2018 Week 31 - 33 Bonus Content
Closed, ResolvedPublic

Description

Completeish

See PHI754. Empty files get detected as copies. This is likely a git issue but we can write it up. (See T13165.)

See PHI751. This looks like a straightforward bug with silent mode and inverse transactions / subeditors.

See PHI743. An install reports project.edit not working properly when setting member lists with more than 100 members. (This was just a caller mistake with other API calls.)

See PHI775, about "More Branches". This is already fixed but should get a followup.

See PHI749. The heuristic for isProbablyJSON() incorrectly detects .gitmodule files which start with [submodule ...] as JSON. This can be made less aggressive.

See PHI785, which asks for explicit "inbound" and "outbound" configuration in cluster.mailers for cases where a provider (e.g., MailGun) is desired for inbound but not configured for outbound.

See T12907. This is impacting an export and important to make work for T13076, too.

See PHI774. An install would like Spaces support in Phriction and Projects.

See PHI765. Some of this ended up in T13166, but improving the push logs to show which rule blocked a push (and, ideally, make them queryable by rule) is simpler and a better fit for the actual need.

See PHI797. An install missed the last modified time in the head of wiki pages, but this is a little weird and there's no precise timestamp available right now.

See PHI766. An install is reporting 18MB chunks written to Harbormaster; the expectation is that logs will be chunked at 1MB. Perhaps a bug when a single 18MB block is written in one go? See also PHI777. (The "fail builds that produce too much output" part of this ended up in T13088.)

See PHI766. File chunks are never accessible directly and should not be indexed by Ferret, but we spend a significant amount of time indexing them in bin/harbormaster rebuild-log.

See PHI766. The --trace flag should include absolute timestamps since startup in output so it can be more useful as a proxy-for-profiling on systems where XHProf is not available (which is a reasonably wide range of systems, including production-ish systems).

See PHI725, which caught a minor issue with parameter validation in transaction.search.

See T12397 and PHI801. The ssh-auth cache currently caches path information too aggressively.

See PHI801. bin/conduit call ... should support an --as <user> flag to make testing and profiling authenticated calls easier.

See PHI805. bin/storage probe renders tables larger than 100GB awkwardly/incorrectly.

See PHI790, which reports an inconsistency in reporting between APCu and APC that possibly points at a more significant issue.

See PHI693. An install notes user confusion over the Differential standalone view incorrectly reporting that changeset navigation shortcuts work. Ideally, at least some of them would actually work, but cause navigation between changeset standalone views.

See PHI788, which asks for some basic UI improvements to the Drydock operations list page.

See PHI748. This reports an issue with the path validation UI in Owners. I've anecdotally experienced something similar.

See PHI823, which reports some specific accessibility concerns with Differential.

Details

Commits
D19586 / rP4d89afcc6149: Remove requireCapabilities() from ApplicationTransactionEditor and require…
D19595 / rP75a5dd8d8cc0: Add more accessibility labels for screen readers
D19594 / rP438edde03150: Add some missing aural button labels for accessibility
D19593 / rPa48e6897a418: Remove obsolete setup check call to Maniphest "Can Edit <X>" field checks
D19592 / rP0ccf1410e057: Give PhabricatorAuthPassword a formal CAN_EDIT policy
D19585 / rP7e29ec2e2a66: Move the "Can Lock Projects" check from requireCapabilities() to transaction…
D19584 / rP3b92da22f433: Move the hierarchical edit policy check in Phriction from requireCapabilities()…
D19583 / rP24d444584548: Remove pointless requireCapabilities() method from PhabricatorRepositoryEditor
D19582 / rPa39852ae1b4a: Remove pointless requireCapabilities() method from…
D19581 / rP296bf046a812: Remove deprecated Maniphest "Can Edit <Specific Property>" capabilities
D19579 / rPf9673a72a87d: Allow "user.edit" to enable or disable users
D19577 / rP65904d7c5137: Add a modern "user.edit" API method for users
D19576 / rP39d415e90eb3: Move users to modular transactions
D19575 / rP9a15129b402f: Remove 750ms timeout on owners path validation
D19574 / rP92a29f72c14c: Make the Drydock repository operation page slightly richer
D19572 / rPb86dae6214ff: Fix an issue with error handling when no mailers are available
D19571 / rPe5906f4e127e: In Differential standalone views, disable some keyboard shortcuts which don't…
D19568 / rP6df278bea84a: In "bin/ssh-auth", cache a structure instead of a flat file because paths may…
D19569 / rPdf31405d64a4: Improve compatibility of "Config > Cache Status" across APCu versions
D19566 / rP3ca3f09a1aa6: Add an "--as" flag to "bin/conduit call ..." to improve flexibility and ease of…
D19567 / rP201f29fbf4ab: Fix truncation in "bin/storage probe" of tables larger than 100GB
D19565 / rPHUdd136d1c3712: In "--trace" output, print elapsed miliseconds for ballparking performance…
D19564 / rPHU88bfaede26af: Improve "--trace" behavior when output includes binary queries
D19563 / rP91abc0f02720: Stop indexing the chunk data objects for large Files stored in multiple chunks
D19562 / rP5839a54b604d: Raise a tailored error when calling "transaction.search" with empty "phids"…
D19560 / rPf3fa164882ea: Add a "Last Edited" property to Wiki pages
D19557 / rPe72296f9274d: Support querying Herald rules by monogram in typeahead datsources
D19556 / rP06380e8079de: Allow push events to be filtered by which Herald rule blocked the push
D19555 / rPd8834377be0c: When a Herald rule blocks a push, show which rule fired in the push log UI
D19551 / rP96e3c73159e6: Put "Subprojects" on top of "Milestones" in the Project UI
D19554 / rP45babe82f364: Add Spaces information to the project list UI
D19553 / rP8d8086fccf96: Add Spaces support to Phriction
D19552 / rP8374201620fe: Add a more specific CSS rule to make Spaces headers in projects colored red
D19550 / rPd9b5b0495088: Improve Space behavior for subprojects and milestones
D19549 / rP13cac5c362bb: Add Spaces to Projects
D19545 / rP9cf3b3bbf806: Count lines in build log slices more cheaply
D19546 / rP690a460c8e8d: Allow mailers to be explicitly marked as inbound or outbound
D19543 / rPa5d3aea67c5b: Carry the "silent" transaction flag through inverse edge edits
D19544 / rPcb99396c64dc: Make the "Is this JSON?" DocumentEngine heuristic a little tighter

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
epriestley updated the task description. (Show Details)Jul 30 2018, 3:26 PM
epriestley updated the task description. (Show Details)Jul 30 2018, 11:28 PM
epriestley updated the task description. (Show Details)Aug 2 2018, 12:54 AM
epriestley updated the task description. (Show Details)Aug 3 2018, 7:16 PM
epriestley updated the task description. (Show Details)Aug 3 2018, 7:27 PM
epriestley updated the task description. (Show Details)Aug 3 2018, 7:29 PM
epriestley updated the task description. (Show Details)Aug 3 2018, 10:09 PM
epriestley renamed this task from Plans: 2018 Week 31 Bonus Content to Plans: 2018 Week 31 - 32 Bonus Content.Aug 6 2018, 4:34 PM
epriestley updated the task description. (Show Details)Aug 6 2018, 10:46 PM
epriestley updated the task description. (Show Details)Aug 6 2018, 11:04 PM
epriestley updated the task description. (Show Details)Aug 7 2018, 9:18 PM
epriestley updated the task description. (Show Details)Aug 8 2018, 6:07 PM

See PHI790, which reports an inconsistency in reporting between APCu and APC that possibly points at a more significant issue.

This is caused by a minor API consistency in apcu_cache_info() fixed by this commit in 2013. Some older versions of APCu report the key as key instead of info (which is the modern value used by APCu, and the historic compatible value used by APC):

https://github.com/krakjoe/apcu/commit/66e5883074348b69957aaf82564fc8136fd3561a

I'm just going to make us check both indexes so we work across versions, since this is a tiny amount of additional complexity.

epriestley renamed this task from Plans: 2018 Week 31 - 32 Bonus Content to Plans: 2018 Week 31 - 33 Bonus Content.Aug 13 2018, 3:11 PM
epriestley updated the task description. (Show Details)
epriestley updated the task description. (Show Details)Aug 13 2018, 4:00 PM
epriestley updated the task description. (Show Details)Aug 13 2018, 5:01 PM
epriestley updated the task description. (Show Details)Aug 13 2018, 6:46 PM
epriestley updated the task description. (Show Details)Aug 16 2018, 2:59 PM
epriestley updated the task description. (Show Details)Aug 16 2018, 9:12 PM
epriestley updated the task description. (Show Details)Aug 17 2018, 6:06 PM
epriestley updated the task description. (Show Details)Aug 17 2018, 6:11 PM
epriestley updated the task description. (Show Details)Aug 20 2018, 10:01 AM
epriestley closed this task as Resolved.