Page MenuHomePhabricator

Plans: 2018 Week 23 - Week 30 Bonus Content
Closed, ResolvedPublic

Description

See T13150. We need to crack down on this in the short term.

See T13152. There's some sort of bug here and the identity stuff should be cherry-picked to stable.

See PHI685. If you stack enough actions in Differential in a tiny window in haunted mode (Z) and your OS doesn't render scrollbars, things get a little confusing. A partial mitigation is to increase the maximum height of the panel.

See PHI684. This is a couple of requests, but the more immediate one is that "Mailable" datasources should include packages, which is quite reasonable.

See PHI654. This is a likely-minor text rendering issue with long package names in the table-of-contents views.

See PHI648, which reports a submodule issue with arc patch --nobranch. This may just get punted but may also be a 5 line fix.

See PHI616. There's a bug with the persistent header when you scroll down to trigger it, then up so it hides, then down again (into the first changeset, but not as far as the second changeset) in Differential. The header should reappear but does not.

See PHI701. There's a coloration bug with unified diffs.

See T13150. Instance invite email throttling appears to be working properly, but the emails are incorrectly omitting sender name information.

See PHI683. An install would like the ability to change object subtypes after the fact. See also T12314.

See PHI702. An install would like a "members of all projects" policy rule.

See PHI647, which requests minor improvements to the mail delivered under "Require Secure Mail".

See PHI686. An install (running an older version) reports metamta.email-body-limit not applying correctly to outbound HTML bodies.

See T12164. There's some rebuild-identities cleanup on a handful of cluster hosts.

See D19493. Some flavor of this is reasonable.

See PHI720. An instance suggests the branch parameter in diffusion.branchquery be passed to git as the pattern to work around T9898. This isn't the most perfect sort of change I could ever imagine, but is probably reasonable.

See T13155, which appears to be a reproducible (and, probably, simple?) bug.

See T13159, which is a minor rendering bug.

See PHI673. An instance would like tables like this to render better (see also T13158) by truncating the object reference instead of wrapping everything else. This was punted to T13160.

See PHI719. An instance has an object with 100,000 comments, which is slow to index. There are several minor improvements we can likely make.

See PHI725, which requests reasonable content fills for some transaction.search events.

See PHI725. The "constraints" parameter for transaction.search is not documented and does not self-document since this isn't a "real" *.search API method.

See PHI727. The dashboard widget typeahead datasource is pretty busted.

See PHI746, which catches some terminology which wasn't updated after UI changes ("dependent revisions").

See PHI622. An install would like access to testPlan from differential.revision.search, which is entirely reasonable.

See PHI616. The remainder of this request discusses creating a "Changes since I last commented" view in Differential. This is probably also T8163.

Revisions and Commits

Restricted Differential Revision
Restricted Differential Revision
rPHU libphutil
D19477
rARC Arcanist
D19475
rP Phabricator
D19541
D19518
D19514
D19511
D19510
D19509
D19507
D19505
D19504
D19503
D19502
D19499
D19500
D19484
D19484
D19489
D19490
D19488
D19487
D19486
D19482
D19480
D19478
D19476
D19474

Related Objects

Mentioned In
T13156: Plans: Improve Phacility UI for managing instance managers and cards
T13164: Plans: 2018 Week 31 - 33 Bonus Content
T13137: Plans: 2018 Week 19 - Week 22 Bonus Content
Mentioned Here
T13164: Plans: 2018 Week 31 - 33 Bonus Content
T13160: Support <colgroup> in the verbose remarkup <table> syntax for specifying column widths
T8163: Show changes since last accepted version
T13156: Plans: Improve Phacility UI for managing instance managers and cards
T13159: The "Config" application renders an extra "Config" crumb
T13155: Empty commit causes diffusion error output (but doesn't fail)
T13158: View query results as annotatable "spreadsheets"
T13141: MySQL 8.0.4+ uses "caching_sha2_password", which is incompatible with older clients and raises error 2054 ("The server requested authentication method unknown to the client") with virtually no setup guidance
D19493: Add a --limit argument to the `workers` management cli.
T9898: `git branch --contains X` has cost in the realm of O(commits * branches)
T12164: Put an indirection layer between author/committer strings and user accounts
T13152: Storage on `secure` was filled by binlogs from looping (?) rebuild-identities script
T12314: Support formal task subtypes (like "bug" vs "feature")
T13073: Plans: Drydock for normal software use cases where builds take more than 45 seconds
T13130: Plans: 2018 Week 17/18 Bonus Content
T13137: Plans: 2018 Week 19 - Week 22 Bonus Content
T13150: Limit the allowed number of open invites for Phacility instances, particularly test instances

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
epriestley updated the task description. (Show Details)Jun 7 2018, 4:27 PM

See PHI649. The file path typeahead in repositories can be difficult to use when your repository has a lot of long paths which all start with /path/to/some/actual/directory/with/source/in/it/com/java/oracle/.

I'm inclined to try making the input take over the entire screen when you select it (basically, change into a full-width dialog), then revert to a normal input if you unfocus it. Not sure how involved that will be.

epriestley updated the task description. (Show Details)Jun 8 2018, 1:55 PM
epriestley updated the task description. (Show Details)Jun 8 2018, 3:20 PM
epriestley renamed this task from Plans: 2018 Week 23 Bonus Content to Plans: 2018 Week 23 - Week 24 Bonus Content.Jun 12 2018, 1:50 PM
epriestley updated the task description. (Show Details)Jun 12 2018, 1:56 PM
epriestley updated the task description. (Show Details)Jun 12 2018, 2:00 PM
epriestley added a revision: Restricted Differential Revision.Jun 12 2018, 2:12 PM

See PHI647, which requests minor improvements to the mail delivered under "Require Secure Mail".

I'm going to add a generic PHID-based URI like https://phabricator.mycompany.com/object/<PHID>/ which redirects to the object page without disclosing any information about the monogram (e.g. #fire-steve, rNUCLEARMISSILECONTROLLER) and include this link in the secure email by default, so the mail will contain a direct link to the impacted object in all cases.

This URI probably already exists in some sense as /search/?jump=true&query=<PHID> but we can pretty it up a bit.

Then, I'm going to add some methods like setNondisclosingMonogram(...) and setNondisclosingURI(...), maybe with nicer names if I can come up with something. These will be called in individual TransactionEditor classes on a manual, case-by-case basis. If they're present, the mail will build with the specified monogram and URI, instead of no monogram and a generic URI.

Finally, I'll call those methods from Differential and Maniphest (since monograms and URIs in those applications are nondisclosing) and probably call it a day. A complete implementation would involve calls to those methods in most applications, just not applications where monograms can disclose information (like Projects and Diffusion).

See PHI676. An install reports a haunting by ghosts. Spooky!

The specific ghost here is the "Create New Bot" form creating non-bot users. I'm unable to reproduce this or find any possible pathway for it to happen in the code, and have never seen other reports.

After users become more transactional in PHI642, just rewriting this flow onto transactions is a possible attack.

epriestley updated the task description. (Show Details)Jun 12 2018, 7:07 PM
epriestley updated the task description. (Show Details)Jun 12 2018, 9:07 PM
epriestley renamed this task from Plans: 2018 Week 23 - Week 24 Bonus Content to Plans: 2018 Week 23 - Week 26 Bonus Content.Jun 21 2018, 2:42 PM
epriestley updated the task description. (Show Details)
epriestley updated the task description. (Show Details)Jun 21 2018, 3:02 PM
epriestley updated the task description. (Show Details)Jun 21 2018, 3:19 PM
epriestley updated the task description. (Show Details)Jun 21 2018, 4:18 PM
epriestley updated the task description. (Show Details)Jun 22 2018, 12:09 PM
epriestley updated the task description. (Show Details)Jun 22 2018, 2:55 PM
epriestley updated the task description. (Show Details)Jun 22 2018, 5:26 PM
epriestley updated the task description. (Show Details)Jun 22 2018, 5:42 PM
epriestley updated the task description. (Show Details)Jun 27 2018, 1:24 PM
epriestley updated the task description. (Show Details)Jun 27 2018, 4:35 PM
epriestley updated the task description. (Show Details)Jun 27 2018, 5:47 PM
epriestley updated the task description. (Show Details)Jun 27 2018, 6:02 PM
epriestley updated the task description. (Show Details)
epriestley updated the task description. (Show Details)Jul 9 2018, 9:31 PM
epriestley updated the task description. (Show Details)Jul 25 2018, 12:19 AM
epriestley updated the task description. (Show Details)Jul 27 2018, 4:28 PM
epriestley renamed this task from Plans: 2018 Week 23 - Week 26 Bonus Content to Plans: 2018 Week 23 - Week 30 Bonus Content.Jul 27 2018, 6:04 PM
epriestley closed this task as Resolved.
epriestley updated the task description. (Show Details)

I kicked a couple things out and moved the rest to T13164 to sort of force things back on some kind of normal-looking track with a plausible connection to realtime.