There are various inconsistencies in class naming conventions that we should probably fix eventually. Many of these are trivial and shouldn't break anything. Some are more involved and will involve migrations.
- Sometimes, abstract base classes are explicitly labelled as such by the presence of Base in the class name. For example, ArcanistBaseWorkflow versus ArcanistLinter (which are both abstract classes). I prefer the latter.
- PhabricatorApplicationSettings is probably clearer as PhabricatorSettingsApplication. There are many classes that follow the former naming convention (some discussion in D9839).
- Conduit API classes are quite hideous and have underscores in them.
- Some class names are prefixed with Phabricator, whilst others are not (for example, DifferentialDiff versus PhabricatorPaste) ----
Original description
I am curious as to why the classes which represent Conduit methods (such as ConduitAPI_flag_delete_Method) have a naming convention that is inconsistent with the rest of the codebase. I was hoping you could clarify the reasoning here.
Would it not be cleaner to have something like:
<?php final class ConduitAPIFlagDeleteMethod extends ConduitAPIFlagMethod { public function getConduitMethod() { return 'flag.delete'; } }