Ref T5655. It is superfluous to include "base" in the name of an abstract base class. Furthermore, it is not done consistently within the code base.
In order to retain compatibility with external code, I have kept the ArcanistBaseWorkflow class (which trivially extends from ArcanistWorkflow), but it is now deprecated and should output a warning message. Similarly for ArcanistBaseUnitTestEngine.