Page MenuHomePhabricator

Make bulk moves easier on Workboards
Closed, ResolvedPublic

Assigned To
Authored By
swisspol
Jul 1 2014, 2:45 PM
Tags
Tokens
"Like" token, awarded by brianespinosa."Like" token, awarded by asherkin."Like" token, awarded by alexmv."Like" token, awarded by azurasean."Like" token, awarded by lyahdav."Like" token, awarded by souljedi."Doubloon" token, awarded by hartman."Like" token, awarded by amire80.

Description

It's labor-intensive to move a large number of tasks around on a workboard.

  • Original task suggests multi-select; this is possible, but quite complicated and probably a lot of JS work.
  • Trello has "Move all cards in this column..." (somewhat specialized, but seems useful in cases where it makes sense?) and "Move to..." (better for long moves?) in context menus.
  • A low-effort, power-user interaction like "option-click a task to move it to to the last column you moved a task to" might be a good workaround. Another possible interaction could be "press and hold 3 to highlight the 3rd column; while holding the button click tasks to move them". These are a little odd but easy to implement.
  • See also some discussion in T4476.

Some groundwork which is likely to be useful no matter what:

  • We can't directly drop tasks into columns in an order-neutral way right now, although I think this is trivial to implement.
  • Converting the "edit column / add task" buttons on columns into a dropdown would let us put more stuff in there; we'll run out of space soon otherwise, and the buttons are a bit mystery-meat even now.
  • This and T5475 may inform each other, in terms of adding dropdown menus to tasks.

Event Timeline

swisspol created this task.Jul 1 2014, 2:45 PM
swisspol raised the priority of this task from to Needs Triage.
swisspol updated the task description. (Show Details)
swisspol added a subscriber: swisspol.
chad triaged this task as Wishlist priority.Jul 1 2014, 10:34 PM
chad added a project: Workboards.
epriestley renamed this task from Allow selecting and dragging multiple tasks in workboards to Make bulk moves easier on Workboards.Aug 8 2014, 4:02 PM
epriestley raised the priority of this task from Wishlist to Low.
epriestley updated the task description. (Show Details)

This also interacts with triggers (T5474).

We would like to request this feature as well, it comes up a lot for us

@ahoffer2, are your use cases covered by "Move all cards in this column to <another column>", or are they more around moving a specific set of cards (but not all of the cards in a column)?

Specific subsets of cards. E.g. "move all resolved bugs from column "in progress" to column "done"", or "move these 30 bugs that I've selected from column "backlog" to column "in progress"".

One problem we have that causes this is:

Drag a task from one workboard column to another. It works, great.
Now click a second task from the first workboard column and try to drag it. Instead of dragging, you activate a text selection. You have to first click on the task, release, and then click drag it. It's a small thing, but pretty annoying when moving lots of tasks at once.

@ahoffer2: What browser are you using? That sounds insanely annoying, but I can't reproduce it immediately.

I can reproduce it in both Chrome and Firefox on Windows, and my co-worker was having the same problem on Firefox on Mac. (I can also send a video if the problem is that my description isn't great.)

qgil added a subscriber: qgil.Dec 17 2014, 8:19 AM

A similar request: Easily close all tasks in a particular workboard column https://phabricator.wikimedia.org/T1284

Would this be solved by a same "batch edit for workboards" solution, or should I file a new task?

fabe added a subscriber: fabe.EditedDec 17 2014, 10:20 AM

Attached diff allows for batch edits of all tasks in a workboard column (only all, no selection possible). And please note that you have to reload the board when you make column moves and want to batch edit afterwards!
Very handy to close all tasks in a column or add/remove a project.

As multiple task selection might be a tricky UI part within the workboards it might be easier to allow a user to deselect a task in the batch editor?
And we'd need to add column moves to the batch editor to fully match these requirements.

qgil added a comment.Dec 17 2014, 2:07 PM

Er... true, and thank you for reminding me about my own tasks submitted. :D

angie added a project: Restricted Project.May 20 2015, 5:10 PM
joshma added a subscriber: joshma.Jun 2 2016, 12:19 AM

hey all,

this is probably my #1 pet peeve.

my expectation would be: have "Move to Workboard Column" available in the "Bulk Edit Tasks" actions.

use cases:

  • "Completed" tasks get moved to "Approved" once the PM gives them a thumbs up. They subsequently get marked as Resolved once they're released.
  • we use Milestones ("Phase 1") which show up as workboard columns, as an alternate destination for tasks rather than "Approved"
amire80 added a subscriber: amire80.

my expectation would be: have "Move to Workboard Column" available in the "Bulk Edit Tasks" actions.

This, indeed.

Move all cards in this column to <another column>

That would be very useful for us as well.

souljedi added a subscriber: souljedi.
kay54068 moved this task from Backlog to Workboards v2 on the Workboards board.Apr 21 2017, 8:29 AM
kay54068 moved this task from Workboards v2 to Backlog on the Workboards board.
alexmv added a subscriber: alexmv.

Any progress on this issue? Agreed with @dariusz that this is my number one pet peeve. This is a pretty large omission from bulk editing capabilities for a column. I can set a task to move to a different column when I am commenting in a task. I'd expect the ability to do the same bulk process on a column of tasks, even if I could only move those tasks within the same workboard. Dragging and dropping tasks individually is extremely time consuming when I have to move tasks between columns.

See Planning for information on progress and priorities.

Will add this as a request for us to our planning log

Pawka added a subscriber: Pawka.Sep 11 2017, 10:32 AM
epriestley closed this task as Resolved.Feb 13 2018, 11:43 PM
epriestley claimed this task.

I think D18665 seems to generally have been satisfactory here, so I'm going to call this resolved until additional use cases arise.