Page MenuHomePhabricator

One-Click Add Task on Workboard Columns
Closed, WontfixPublic

Description

With a recent Workboard consolidation of actions, we've made it harder to discover or quickly add tasks to a column. We should have a one-click means of task creation.


Original request:

I was trying out the new wallboards features and noticed that it wasn't initially obvious how to create a task on the workboards.

I used my powers of exploration to find that it was hidden in the arrow drop down menu at the top of the column. My first impression was that this menu was for configuring details about the column.

I propose a dedicated link/button for each column for creating tasks in the context of that column.

Event Timeline

waynea created this task.Sep 10 2014, 3:50 AM
waynea raised the priority of this task from to Needs Triage.
waynea updated the task description. (Show Details)
waynea added a project: Workboards.
waynea added subscribers: waynea, hach-que.
chad closed this task as Wontfix.Sep 11 2014, 4:32 PM
chad claimed this task.

The concern here is that some links are accessible and some are not. We'd prefer to stick with the consistent dropdown for the time being, but we may look into it again if we decide to build fixed height columns.

I respectfully disagree with your decision because consistency and an Intuitive user interface are not the same thing. I'm finding in a lot of case the one size fits all approach to UI on Phabricator can get a little verbose.

I'm happy to raise tasks for all these use cases with some mockups if it you'd be open to considering them?

chad added a comment.Sep 11 2014, 10:35 PM

I may be misunderstanding your request. Is it that you want empty columns to have a create link or all columns to have a create link.

The create link under all columns was how the product was initially designed and built (see M15). We junked that since the links would be offscreen or thousands of pixels apart. We then had a + in the header for adding new tasks instead. It looks like that was changed / moved recently, so we should look at adding that back if its confusing.

I got some some similar feedback which I would summarize as "reduce
number of actions needed to create a new task".

chad added a comment.Sep 11 2014, 11:22 PM

Yeah I think there may be a UI regression, in that we did have a + in the header to quick add a task. I cc'd @epriestley to see if he remembers.

See D10190 for discussion. The change was intentional.

@epriestley in the discussion it was never really resolved as to why 2 clicks is better that 1 click. As a user who was batch adding a number of tasks this was frustrating to click twice.

In regards to the making it more intuitive for first time users; when I first went to the Workboards page to try it out, I was unsure how I was meant to create a new task. It was only until I went into exploration mode did I find the controls.

At risk of sounding wishy-washy I'm convinced an excellent UI works at sub conscious level and that users have an almost reaction to the controls. I think as software developers we may take exploring UIs, API etc for granted. I would imagine that you are aiming Workboards at project managers and other non-technical users?

We haven't seen other reports of users having difficulty finding this functionality, and it now says "New Task" explicitly instead of being sort of a mystery meat "+" icon. Even if this change is worse for discovery on the balance, I don't think it has made a very large impact either way. In this case, you found the interaction, even if it wasn't where you expected it to be.

We might reevaluate this after T5024, T4427, T5474, T5523, and T5475.

I don't really have any objection to adding a link a the bottom of the columns, but, as @chad mentions, it will sometimes be inaccessible (scrolled off screen) and I don't think we can drop it into the current design without adjusting things (there's no slot for it in the element as it currently exists).

In general, I don't think the slightly harder discovery or the extra click have a significant effect on the interface, even if they are worse, and aren't worth dealing with now given that the changes aren't trivial and may be undone, obsoleted, or interact negatively with other planned work.

We do think carefully about UIs, and are aiming them at all users.

@epriestley is there a better way to bulk add tasks than using the Workboard UI, because that is when the action became frustrating, maybe a link in the drop-down to bulk add would help if it exists?

I agree with @chad that it would be inaccessible at the bottom, so if you were going to include it in the Workboard UI it would be better to be at the top of the column under the column heading and just above the top most task.

If you look at the Workboards equivalents in Trello and Jira you will find that they both have buttons with an explicit Call to Action to create or add. This is a familiar pattern in Workboard style UIs. I can go do some UX tests with users at our org and observe their behaviour @hach-que and I have done this before with the Harbour Master UI and it was very useful.

I don't mean any disrespect in regards to the thought you've all put into the UI. I hope this feedback is helpful.

chad reopened this task as Open.Sep 12 2014, 1:45 AM

I'd agree we should have a one-click add task. we'll look into adding it back somewhere.

chad renamed this task from Create Task link/button in Wallboard Columns to One-Click Add Task on Workboard Columns.Sep 12 2014, 1:48 AM
chad updated the task description. (Show Details)
chad triaged this task as Normal priority.Sep 12 2014, 5:07 PM
fanis added a subscriber: fanis.May 19 2015, 3:05 PM
epriestley moved this task from Backlog to Workboards v2 on the Workboards board.

I'm going to try to bludgeon this in for EditEngine, we can refine it in Projects v3 if I ham it up.

chad added a comment.EditedDec 8 2015, 11:20 PM

In some regards, having "bug report", et al. on a column might feel weird. Or do you have something in mind?

Not really. I was going to do this:

+---------------------------------+
| Backlog       ( 0 ) [ + ] [ V ] |
+---------------------------------+
| ...                             |

..where the "+" means "Create Task" if there's only one form, and is a dropdown if there are several. On this install for us (and members of Community), it would show:

  • New Advanced Task
  • New Bug Report
  • New Feature Request

For normal users, it would show bug/feature.

I can just point the existing link at the user's default edit form instead and not do this task for now if that feels weird to you.

("Not really." in the sense of "I don't have anything in mind" -- I agree that it might feel weird.)

chad added a comment.Dec 8 2015, 11:27 PM

Yeah, maybe it's not terrible, will have to see what other feedback we get here is. One idea might be to allow columns to define what forms are there, with all forms by default on the Backlog.

epriestley reassigned this task from epriestley to chad.Dec 8 2015, 11:30 PM

After "thinking carefully" about this I am going to do the lazy / less bold approach and we can sort it out later so you can have this back. :3

chad added a comment.Dec 8 2015, 11:38 PM

yeah maybe lazy is bestest

eadler added a project: Restricted Project.Aug 5 2016, 5:23 PM
venky added a subscriber: venky.Aug 15 2016, 11:36 PM

Starting to try out Workboards (we're coming from Trello), and I felt the absence of this feature as well.

bar350 added a subscriber: bar350.Sep 2 2016, 2:01 PM
JohannesMP added a subscriber: JohannesMP.EditedOct 28 2016, 11:03 AM

+1 - quickly adding several tasks to a given column does currently feel quite tedious

There are probably better ways of modifying this, but for my team's phabricator I added the + button back in: https://secure.phabricator.com/P2015 which has helped a lot.

jcox added a subscriber: jcox.Jan 19 2017, 10:27 PM
epriestley closed this task as Wontfix.Nov 28 2017, 5:07 PM

I don't plan to pursue this.