Page MenuHomePhabricator

Unbeta Ponder
Closed, ResolvedPublic

Description

Umbrella task for things to move Ponder out of beta.

Details

Differential Revisions
D6486: Use ApplicationSearch in Ponder
Commits
D13920 / rP13346ea90430: Unbeta Ponder
D13891 / rP9e306710b359: Clean up misc Ponder details
D13886 / rP3db9e4b4e5a2: Add mailtags to Ponder
D13786 / rPe05e539a9c10: Clean up Ponder CSS
D13792 / rPa3b955f948c8: Add Spaces to Ponder
D13793 / rPfdc1662bfd91: Add Projects to Ponder Search View
D13791 / rP135d0c9ee7a6: Add Edit/View Policy to Ponder Questions
D13784 / rP328210a1a645: Add mobile menu to Ponder
Restricted Differential Revision / rPb2fa1293a744: Use PHUIRemarkupPreviewPanel in Ponder
Restricted Differential Revision / rP1fd2d28b11ef: Restore mail to Ponder
Restricted Differential Revision / rP4308a932c20c: Restore search indexing to Ponder questions
Restricted Differential Revision / rP5cc3bbf721fc: Use application PHIDs for application transactions
Restricted Differential Revision / rP5037ba1cf8d8: Restore voting to Ponder
Restricted Differential Revision / rP1720d651da3f: Restore feed stories to Ponder
Restricted Differential Revision / rP6172f2bbd18e: Require answers' authors to be unique in Ponder
Restricted Differential Revision / rP8fa594476867: Make adding an answer to a Ponder question a QuestionTransaction operation
Restricted Differential Revision / rPe6967ed2ec30: Clean up more PonderQuestionQuery cruft
Restricted Differential Revision / rPd07d52645ff1: Remove two unused Ponder views
Restricted Differential Revision / rPce16369f8e3f: Use Application PHIDs for ANSW
Restricted Differential Revision / rPf98ca03d7df5: Clean up more PonderAnswer cruft
Restricted Differential Revision / rP7522b45ef2c3: Clean up some PonderAnswer / PonderAnswerQuery cruft

Event Timeline

epriestley added subscribers: epriestley, chad, btrahan, pieter.
epriestley triaged this task as Normal priority.
epriestley edited this Maniphest Task.Jul 18 2013, 2:02 PM
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.Jul 18 2013, 2:06 PM
epriestley edited this Maniphest Task.Jul 18 2013, 2:10 PM

T3583 discusses surfacing content on the home page.

epriestley edited this Maniphest Task.Jul 26 2013, 8:01 PM
epriestley edited this Maniphest Task.Jul 26 2013, 8:14 PM
epriestley edited this Maniphest Task.Jul 26 2013, 8:31 PM
epriestley edited this Maniphest Task.Jul 26 2013, 8:34 PM
chad added a comment.Jul 26 2013, 8:40 PM

This has a suspicious lack of tasks.

epriestley edited this Maniphest Task.Jul 28 2013, 10:09 PM
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.Jul 28 2013, 10:40 PM
epriestley edited this Maniphest Task.Jul 28 2013, 11:05 PM
epriestley edited this Maniphest Task.Jul 28 2013, 11:32 PM
epriestley edited this Maniphest Task.Jul 29 2013, 2:29 AM
epriestley edited this Maniphest Task.Jul 29 2013, 1:40 PM
epriestley edited this Maniphest Task.Jul 29 2013, 1:52 PM
epriestley edited this Maniphest Task.Jul 29 2013, 3:22 PM
epriestley edited this Maniphest Task.Jul 29 2013, 3:39 PM
epriestley edited this Maniphest Task.Jul 29 2013, 7:04 PM
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.Jul 31 2013, 1:42 PM
epriestley edited this Maniphest Task.Aug 5 2013, 2:22 AM
epriestley edited this Maniphest Task.Aug 5 2013, 5:47 PM
epriestley edited this Maniphest Task.Aug 22 2013, 12:24 PM
btrahan edited this Maniphest Task.Sep 18 2013, 9:23 PM

Feel free to kick this back if it's not too thrilling, but there are some larger chunks of product work which could get Ponder to a more promising state if you're interested. You can pick-and-choose here if some of this is stuff you want to do and other parts aren't.

Ponder isn't a great application right now, but I want to go through another couple of iterations on it before we give up on it. Here are the major issues I see with it, roughly in order of importance, and my proposed fixes:

No Herald Integration: T6919. We have Ponder disabled here in the upstream because there's no way to keep track of when users ask questions. This lead to things not getting touched for a long time. Herald integration won't solve this problem completely, but would solve it in the upstream case by allowing us to receive email notifications when new questions are asked. This would let us re-enable Ponder in the upstream and at least get it off the path toward deletion.

Remove Voting: T6920. Ponder features voting, which makes sense for a large, public site like StackOverflow or Quora where many thousands of users might read a question and the userbase is the general public. Most Phabricator installs have a small number of users, and voting does not create a useful signal at small scales. We can provide better mechanisms for solving the problems voting solves, without cluttering the UI and codebase.

Support Merging: T6921. There's no way to close a question as a duplicate of another question, but there should be, similar to Maniphest.

There's probably still a lot of work after that, but I think fixing that stuff might be enough to make the application not feel like a total dead end.

epriestley removed lpriestley as the assignee of this task.Apr 26 2015, 5:58 PM
chad changed the visibility from "All Users" to "Public (No Login Required)".
eadler added a subscriber: eadler.Aug 4 2015, 9:44 PM
chad moved this task from Backlog to Unbeta on the Ponder board.Aug 7 2015, 12:22 AM
chad claimed this task.
chad added a comment.Aug 12 2015, 5:16 PM

Open questions for me:

  • Should we add an actual "archive" for questions and answers (or delete)
  • Should moderators be able to "archive" a question or answer.
  • Should we add "best answer" for asker / moderator
  • Should we remove "helpful"
  • Should new answers be permitted on closed questions
  • ???

The UI still needs polish, but these are the remaining feature questions I have

chad closed this task as a duplicate of T9184: Remove IRC based support.Aug 14 2015, 5:40 PM
chad reopened this task as Open.

gah

kubilayeksioglu moved this task from Unbeta to v2 on the Ponder board.Aug 18 2015, 5:13 PM
kubilayeksioglu moved this task from v2 to Unbeta on the Ponder board.
chad closed this task as Resolved by committing rP13346ea90430: Unbeta Ponder.
urzds added a subscriber: urzds.Jul 12 2017, 11:14 AM