Page MenuHomePhabricator

Plans: 2018 Week 34 Bonus Content
Closed, ResolvedPublic

Description

See PHI807, which touches on a documentation improvement about what phd.taskmasters does.

See PHI834, which reports a Mercurial 4.7 protocol issue.

See T13176, the "/new/" link in revisions shouldn't appear on the first mail.

See https://discourse.phabricator-community.org/t/task-priority-change-info-missing-in-firehose-webhook/1832, which requests "priority" transactions for tasks. These are likely trivial and "status" transactions are already supported.

See PHI836, which identifies a minor CSS layout issue.

See PHI811, which suggests swapping the default tab if the file tree is enabled. There are also a couple of scattered reports of file tree / mobile issues.

See PHI802, which requests updated CircleCI support. (This seems to be a mess; see T13188.)

See PHI838, which identifies a likely issue in hunk joining in Bundles.

Event Timeline

epriestley triaged this task as Normal priority.Aug 16 2018, 9:12 PM
epriestley created this task.
epriestley updated the task description. (Show Details)Aug 17 2018, 6:09 PM

See PHI757. Leaving inline comments on the right hand side of files not touched by diff B in an interdiff between A and B raises an error.

This is at least somewhat involved. Related behavior:

  • In the standalone view, you can leave comments on either side -- and they swap sides!
  • Deleting comments from either side raises a JS error ("TypeError: null is not an object (evaluating 'templates.r')"). (Actually, this looks like it applies to all standalone deletion?)
epriestley updated the task description. (Show Details)Aug 20 2018, 10:01 AM
epriestley updated the task description. (Show Details)Aug 20 2018, 10:07 AM
epriestley updated the task description. (Show Details)Aug 20 2018, 10:14 AM
epriestley updated the task description. (Show Details)Aug 21 2018, 8:11 PM

See PHI757. Leaving inline comments on the right hand side of files not touched by diff B in an interdiff between A and B raises an error.

This is at least somewhat involved. Related behavior:

  • In the standalone view, you can leave comments on either side -- and they swap sides!
  • Deleting comments from either side raises a JS error ("TypeError: null is not an object (evaluating 'templates.r')"). (Actually, this looks like it applies to all standalone deletion?)

We're working on a reproduction case for something vaguely related. The user's feedback was:

In a revision, a file was moved and then deleted. A diff-of-diffs that contains the delete but not the move shows the file in two places (the original location and the final location). There's no indication in the UI that the file was deleted, and the first occurrence of the file shows its full content - trying to add a comment to it fails with the error `Invalid changeset ID "0"!` This is super confusing - in practice, I only need to see the file in the final location, and I need to know that the file has been deleted.

We will continue on getting the repro figured out unless you believe this is just a different manifestation of the same underlying bug.

unless you believe this is just a different manifestation of the same underlying bug.

I think it's likely the same thing, yeah. If you stumble across a repro feel free to forward it along, but I'd guess the same fix will resolve both that issue and the substantially similar report in PHI757.

epriestley updated the task description. (Show Details)Aug 24 2018, 4:24 PM
epriestley updated the task description. (Show Details)Aug 24 2018, 5:06 PM
epriestley updated the task description. (Show Details)Aug 24 2018, 5:30 PM
epriestley updated the task description. (Show Details)Aug 24 2018, 7:56 PM
epriestley updated the task description. (Show Details)Aug 24 2018, 8:47 PM
epriestley updated the task description. (Show Details)Aug 25 2018, 12:25 AM
epriestley closed this task as Resolved.Aug 25 2018, 12:38 AM
epriestley claimed this task.

I punted the rest of this to T13189.