Page MenuHomePhabricator

Create the ability to show a Trello style view for projects.
Closed, ResolvedPublic

Tokens
"Like" token, awarded by michaeloa."Love" token, awarded by NorthIsUp."Like" token, awarded by allan.laal."Love" token, awarded by v3knet."Like" token, awarded by sylreboux."Like" token, awarded by xiaogaozi."Love" token, awarded by jevripio."Love" token, awarded by sascha-egerer."Like" token, awarded by svemir."Love" token, awarded by ahtinurme."Like" token, awarded by boruchy."Like" token, awarded by andytruong."Like" token, awarded by cmanon.
Assigned To
Authored By
Stubbs, Jun 12 2012

Description

It would be great to be able to provide a Trello style view of projects from Phabricator and let users run their projects in a Kanban stylee.

I think the only way to do this at the moment is to create a project for each column on the board and then assign each task to multiple projects, but that doesn't give us an overall view of where each task is per project.

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

Maybe Trello has an api? ;)

One of the most valuable features of tools like Trello and Pivotal Tracker is the ability to fully prioritize a set of tasks. This is most useful for feature requests. Rather than saying "This is a high priority task", tasks are placed in a prioritized order and can easily be shuffled.

I'd envision something like this being implemented in phabricator by adding an additional task priority 'backlog'. Backlog tasks would be normal tasks, but displayed at a lower priority than wishlist. There would also be a separate backlog manager feature that would allow the backlog items to be reordered.

The workflow would be to create backlog items based on feature requests, prioritized those features in the backlog manager, and then split out those features into subtasks.

You should already be able to prioritize tasks within a top-level priority group by dragging and dropping them using the colored handles on the left -- here's a screen shot (of course, you need to be looking at them in a priority-ordered view for this to be available):

{F18623}

Is that not what you mean? If not, how would you imagine this feature working?

As for "backlog", can you simply use "Wishlist" as a synonym for "Backlog"?

Wow, thanks Evan. I guess I need to upgrade my instal. That looks like it is exactly what I wanted.

And yes, Wishlist definitely can be synonymous with backlog.

Cool. Those handles are definitely really hard to discover right now, but they should work well enough. Generally, we can definitely improve this stuff a lot once I get some time to focus on it.

Let us know if you run into anything else.

chad added a subscriber: chad.Oct 19 2012, 4:50 PM
epriestley edited this Maniphest Task.Feb 9 2013, 7:20 PM
chad claimed this task.Feb 9 2013, 7:44 PM

so pretty :3

Random thoughts:

For priorities, I don't think we need the labels in this view. We can retain the colors, and when you drag between columns we'll adjust priorities if necessary (e.g., if you drag something above an "unbreak now!", it will become "unbreak now!") and have some separate "set priority", but I would guess they're not important enough in this view to dedicate that much UI to (the order gives you a pretty good idea anyway).

Labels for "Today" and "Tomorrow" might make sense? Probably a v2 thing. Another good v2 thing might be sorting "Complete" by date completed rather than priority.

Also, what do you think about making the whole page scroll instead of just the columns?

I like Trello's "add a card" on each column vs a global button. Maybe "+" next to settings-gear?

chad added a comment.Feb 25 2013, 4:48 PM

Yeah these are some of the things I wanted to catch up over chat/voice with, there are some oddities I run into when I play this out in my head, like where all to put an add task button (I didn't mock it, but planned on doing that today as a first column thing only). Trello is way more open/fluid than we can really need for Maniphest.

Maybe the labels only appear once you start to drag a task around? The main thing for me was giving a solid indicator of what's going to happen when you drop the task somewhere and there weren't others around to dictate priority.

I've got to get the kid to school but will be back in an hour, will ping you on IRC.

chad edited this Maniphest Task.Apr 1 2013, 8:55 PM
cmanon added a subscriber: cmanon.Apr 25 2013, 4:10 PM

@chad As soon as this gets anywhere near Alpha let me know and I'll get it installed on a VM to test.

chad added a comment.May 2 2013, 8:55 PM

My guess is it is likely to be a 'shortly after SaaS' project for us, maybe Q3. Current Roadmap for the year:
https://secure.phabricator.com/w/roadmap/

chad removed chad as the assignee of this task.May 6 2013, 4:16 AM
svemir added a subscriber: svemir.Aug 23 2013, 7:19 PM
chad claimed this task.Oct 18 2013, 4:47 PM
chad added a project: Workboards.
epriestley edited this Maniphest Task.Oct 21 2013, 1:38 AM
epriestley edited this Maniphest Task.Oct 22 2013, 4:12 AM

The tasks are moved randomly on every page reload between the columns. Is that the current expected behavior?

How did you discover the secret board view? It's a secret!

Nothing is secret from NASA

@Stubbs NASA? Sure NSA is using NASAs satellites...
@epriestley I haven't discovered it. Just dreamed about it

osdiab added a subscriber: osdiab.Nov 5 2013, 7:03 PM
chad edited this Maniphest Task.Nov 6 2013, 8:13 PM
tlack added a subscriber: tlack.Dec 2 2013, 9:46 PM
epriestley edited this Maniphest Task.Jan 12 2014, 9:46 PM
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.Jan 12 2014, 10:01 PM
epriestley edited this Maniphest Task.Jan 12 2014, 10:51 PM
epriestley edited this Maniphest Task.Jan 12 2014, 10:53 PM
epriestley edited this Maniphest Task.Jan 12 2014, 11:36 PM
epriestley edited this Maniphest Task.Jan 13 2014, 12:35 AM
epriestley edited this Maniphest Task.Jan 13 2014, 12:51 AM
chad edited this Maniphest Task.Jan 13 2014, 1:30 AM
epriestley edited this Maniphest Task.Jan 13 2014, 1:31 AM
epriestley edited this Maniphest Task.Jan 13 2014, 1:45 AM
epriestley edited this Maniphest Task.Jan 13 2014, 5:40 AM
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.Jan 13 2014, 8:23 PM
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.
epriestley edited this Maniphest Task.Jan 13 2014, 8:31 PM
epriestley edited this Maniphest Task.Jan 13 2014, 10:25 PM
epriestley edited this Maniphest Task.Feb 10 2014, 11:54 PM
epriestley edited this Maniphest Task.Feb 11 2014, 12:14 AM
boruchy edited this Maniphest Task.Feb 11 2014, 7:07 PM

I just tried the beta version, some findings:

A bug:

  • After using the quick edit panel to edit a task, the dialog disappears but the white modal stays and the page would not be refreshed until I force it to do so. The edit itself succeed

Missing Features:

  • The columns cannot be resorted, I think it would be useful if they could be
  • There is no batch moving between columns, or within a column, which is inconvenient

How would you want batch moves within a column to work?

ctrl or shift select 2..N tasks and then drag&drop them similarly like now with the 1 task. It should preserve the order they were in.

@epriestley

That is actually a good question, I can see how the expected behavior is unclear. The use case I had was to move a group of tasks in Need Triage into somewhere in other priorities. Need Triage is like an Inbox for me and then I will prioritize the tasks in that into more specific ones.

I think implementing such a feature would be very complex, and behaviors would rapidly become ambiguous if you selected tasks from several columns. For example, suppose you multi-select tasks from columns A and B, and then drag-and-drop them all into column B. How should they be ordered? Or if you drop them all into column C, how should they be ordered? This would also limit our ability to attach actions and restraints to columns (like "tasks must be assigned to be dropped into this column"), since we'd have to either provide a bulk editor or give you a looping workflow where you assigned tasks one at a time. Other constraints might be more difficult to implement. We could restrict you to selections from only one column, but I think that would produce unintuitive behaviors in some cases. We also don't have any code driving drag-reticle selection modes, and shift-clicking without a selection-modal interface feels iff to me, and much less useful for dragging multiple tasks (since you'd have to click each one at least once). We might pursue this eventually, but I think it would be really complex to implement, have a lot of weird edge cases, and often interact with other features in a complex/limiting way.

The edit task thing and column reordering are definitely things we'll fix, though.

mbishopim3 edited this Maniphest Task.Feb 12 2014, 8:28 PM
kouiskas edited this Maniphest Task.Feb 13 2014, 5:15 PM
epriestley changed the visibility from "All Users" to "Public (No Login Required)".Feb 13 2014, 5:28 PM
chengyin edited this Maniphest Task.Feb 25 2014, 11:20 PM
chad edited this Maniphest Task.Mar 4 2014, 9:18 PM
epriestley edited this Maniphest Task.Mar 6 2014, 6:34 PM
chad added a comment.Mar 21 2014, 8:28 PM

@epriestley, wondering if we can close this. As the task stands, it is "complete" but not fully polished. (It is also not gated as beta).

chad added a comment.Mar 21 2014, 8:32 PM

Generally speaking, I like the idea of dogfooding the progress of Workboards, by using Workboards.

https://secure.phabricator.com/project/board/773/

epriestley closed this task as Resolved.Mar 21 2014, 8:34 PM

Yeah, I think this task isn't too useful anymore. The linked tasks have specific followup stuff.

epriestley closed subtask Restricted Maniphest Task as Resolved.Jun 25 2014, 12:49 PM
chad edited this Maniphest Task.Jun 25 2014, 3:08 PM