Page MenuHomePhabricator

Phabricator does not show project color in Projects Typeahead field
Closed, ResolvedPublic

Description

The default blue color is always shown regardless of the specific project settings.

Revisions and Commits

Event Timeline

igorgatis raised the priority of this task from to Needs Triage.
igorgatis updated the task description. (Show Details)
igorgatis added a project: Phabricator.
igorgatis added subscribers: igorgatis, daniel.arraes.
chad added a subscriber: chad.Jul 30 2014, 3:06 PM

Where specifically is this?

chad renamed this task from Phabricator does not show proect icon in "Projects" text field to Phabricator does not show project icon in "Projects" text field.Jul 30 2014, 3:07 PM

While editing a task:

People use icons and colors to differentiate types of projects. Sounds like people have a demand for better differentiation between projects that represent a group of people and projects that represent something else. In the UI, I'd rank group projects higher for fields which are more related to people.

chad added a comment.Jul 30 2014, 3:29 PM

OK, I assumed this would have been completed with T4420, but it was either missed or I can't find the precise task.

chad renamed this task from Phabricator does not show project icon in "Projects" text field to Phabricator does not show project icon in "Projects" Typeahead field.Jul 30 2014, 3:30 PM
chad triaged this task as Normal priority.
chad edited projects, added Projects; removed Phabricator.
chad added a subscriber: epriestley.
btrahan closed this task as Invalid.EditedJul 30 2014, 6:48 PM
btrahan claimed this task.

This doesn't reproduce on this install. For example, I edited this task (though I didn't save it) and added two more projects that have customized icons:

I think the issue might be confusion about the profile picture versus the icon. For example, on this install, Aphlict has a pretty profile picture but the standard icon. It is showing correctly on this install. Note on the first screenshot the "looks like" UI:

...and here's the edit screen for kicks

AFAIK we don't have plans to let these typeahead icons get too crazy (unlike the infinitely customizable profile pictures), and instead be a standard colors / formats.

chad added a comment.Jul 30 2014, 6:50 PM

Well, we're not doing tag colors at least, the icon is correct.

btrahan reopened this task as Open.Jul 30 2014, 6:50 PM

Whoops, I take back the "this is working just fine" bit in that the colors are not showing up. (e.g. Phacility High Command is actually purple and isn't in the screenshot I provided.)

We could add the colors but I want to wait until after T4100 since that might be a stronger argument for use of color.

btrahan removed btrahan as the assignee of this task.Jul 30 2014, 6:58 PM
btrahan added a subscriber: btrahan.

Okay, I'll just toss this back into the heap for now.

btrahan renamed this task from Phabricator does not show project icon in "Projects" Typeahead field to Phabricator does not show project icon color correctly in "Projects" Typeahead field.Jul 30 2014, 6:58 PM
btrahan updated the task description. (Show Details)

I'd like to emphasize that the ideal would be Project differentiation. In my phab instance, we're using prefixes. E.g. [G] SomePeople to name the group of people, [T] MyTag, [L] LibBar, etc.

chad added a comment.Jul 30 2014, 7:09 PM

That is why icons and colors are provided, so each install can make their own tool. Are you wanting another layer on top of project creation that does icon/color for you automatically?

chad added a comment.Jul 30 2014, 7:09 PM

"Project Templates" or something?

So, the icon shows up, but the color doesn't.

And yes, a bit differentiating projects might be useful. In fields "Visible to" and "Editible by" I'd like to get list of people ranked higher. In the "Projects" field, I'd like to get list of tags ranked higher.

The specific issue with color is that, after T4100, I want it to be clear when you've selected a parameter/variable in a typeahead, like "My Projects", "Members of Project X", "Me", etc. These values will resolve dynamically at runtime.

If we colorize the tokens now, we may need to adjust the colorization after T4100 if we can't find a way to clearly communicate which tokens are variables vs normal tokens without visual ambiguity. This could be confusing, since the tokens would colorize in one way and then later change to colorize in a different way.

Basically just a UI question: how do we show both "variable" tokens and project tokens in a way that they each stand out unambiguously? Something like a different border style or different tag shape might work, or a different font style or weight, or just colorizing only the icons for projects, or something else, but I'm hesitant to colorize project tokens until we have a path forward here that we're happy with.

chad added a comment.Jul 30 2014, 7:28 PM

The solution may include Indigo.

michaeloa added a subscriber: michaeloa.EditedAug 7 2014, 12:11 PM
In T5746#26, @igorgatis wrote:

I'd like to emphasize that the ideal would be Project differentiation. In my phab instance, we're using prefixes. E.g. [G] SomePeople to name the group of people, [T] MyTag, [L] LibBar, etc.

This is essentially the same that we have ended up doing, but it's an ugly solution.

I'd say that there are actually two needs that we have in this respect, neither of which is unfortunately fulfilled with the icon/color thing.

  • Sorting/grouping projects according to the "type" of project.
  • Querying according to the "type" of the project. If I want to find a specific team, I do not also want to browse through miscellaneous tags, administrative units and other projects - I just want to see the teams.

Having explicit differentiation isn't the only way to handle this, but it does seem to be the most straightforward approach.

chad added a comment.EditedAug 7 2014, 2:44 PM

Where do you want this additional sorting, on /project/ page itself? I could see adding icon/color to the list of options to query/group on in ApplicationSearch.

Yeah, doing so from the /projects/ page would seem to make sense. At least that's my go-to place when I need to find projects.

Adding search on icon and color would solve at least part of the issue.

I'd like sorting in the "Visible to", "Editable by" and "Projects" fields in task edition pages.

chad added a comment.Aug 7 2014, 7:46 PM

Added T5819 for additional queries around icon and color as a starting place. T4011 is a more general task for building a new /project/ home.

qgil added a comment.Oct 31 2014, 12:46 PM

If we colorize the tokens now, we may need to adjust the colorization after T4100 if we can't find a way to clearly communicate which tokens are variables vs normal tokens without visual ambiguity.

In terms of UX priorities, I think the first priority is that whatever exists today is consistent. A red token is a red token, and if it shows blue somewhere, they you are colorizing it already. For no good reason (today).

Yes, variables need to look different, but maybe you can do that simply by reserving an icon and a color only available for them.

chad renamed this task from Phabricator does not show project icon color correctly in "Projects" Typeahead field to Phabricator does not show project color in Projects Typeahead field.Nov 1 2014, 3:09 PM

We're still looking at possibly tweaking things a bit here (e.g., see T7858) but project tokens/tags now have consistent coloring.

epriestley closed this task as Resolved.Apr 19 2015, 6:21 PM
epriestley claimed this task.