Page MenuHomePhabricator

UX for new administrators on fresh installs
Closed, DuplicatePublic

Description

When we replace home with dashboards, we'll no longer have a default home page to show administrators when they first login during setup.

On the balance, I think this is probably good thing, since the current default home page is not very useful, especially on a fresh install.

Two possible approaches:

  1. Just automatically build a "reasonable" default dashboard and install it on startup.
  2. Or, do something more onboarding/setup-focused.

(1) is straightforward, but a bit messy technically (for example, we're rarely going to test it -- especially if it's only on the install workflow -- and it's hard to unit test, and it's generally worse to break something on setup/install than elsewhere). It also won't be a very good first experience (everything will be empty) and it will have all the issues the current homepage does (being an OK fit for a lot of users, but a good fit for very few).

I'd like to experiment with (2), and build something that provides a more structured setup workflow for administrators, and guides them through setup tasks. Particularly:

  • Set up authentication (there's a small hint about this in setup issues, but it could be expanded on);
  • configure settings (there are almost no pointers to this);
  • install/uninstall/pin applications;
  • build a dashboard to replace this workflow.

And then maybe some general links to "learn more about tasks", "learn more about code review", etc.

Generally, I think we've had good luck with the "X unresolved setup issues" workflow, and want to try expanding that into onboarding -- the idea being "Quest Tracker" (optional, asynchronous, random-access, non-modal), not "Wizard" (sequential, mandatory, modal).

I think we'll also need/want some degree of dashboard templating or prefabrication, but can build that in a more tailored, testable workflow.

Event Timeline

epriestley updated the task description. (Show Details)
epriestley raised the priority of this task from to Normal.
epriestley added a project: Dashboards.
epriestley edited this Maniphest Task.Jun 11 2014, 3:55 PM

Here's roughly where I'm headed with this, so far:

chad added a comment.Jun 17 2014, 5:42 PM

I need to fix header colors.

chad added a comment.Jun 17 2014, 5:42 PM

Looks great otherwise!

epriestley edited this Maniphest Task.Jun 21 2014, 8:44 PM
epriestley edited this Maniphest Task.Jun 22 2014, 3:05 PM
epriestley edited this Maniphest Task.Jun 22 2014, 5:29 PM
epriestley moved this task to Evan on the Dashboards board.Jun 22 2014, 8:41 PM
epriestley edited this Maniphest Task.Jun 23 2014, 4:38 PM

Support Impact This is generally a support-focused feature.

What's next here? This seems like a good one to get done close to the Phacility launch and / or iterate on soon after?

I think we can remove Support Impact from this. I've seen fewer setup/install-realted issues recently, and imagine this is going to be a long-tail task with a lot of ongoing tweaks that probably should happen post-Phacility.

I think the blockers here are:

  • Dashboards need to be in good shape because the exit from the "Quest Tracker" is to replace it with a dashboard. They have a few stragglers kicking around like some policy stuff, and I think the templates / first-time-user workflow could be better.
  • The actual quest tracker thing could probably use a bit more work and polish. I think it's mostly OK, but still looks kind of complex and overwhelming to me.
chad added a comment.Jan 5 2015, 11:45 PM

I'd probably look at making "Admin Quest Tracker" and "Setup Issues" a Dashboard Panel for Admins... somehow.

epriestley moved this task from Backlog to Do After Launch on the Phacility board.Jan 6 2015, 5:31 PM
chad claimed this task.Dec 22 2015, 11:28 PM
chad raised the priority of this task from Normal to High.
xiangzhitong moved this task from Evan to Chad on the Dashboards board.Feb 17 2016, 6:53 AM
epriestley moved this task from Chad to v2 on the Dashboards board.Feb 19 2016, 3:15 PM
epriestley edited projects, added Dashboards (v2); removed Dashboards.
chad added a comment.Jun 9 2016, 3:37 AM

parrot

im gonna do this task. im gonna do it up real nice.

chad closed this task as a duplicate of T11132: New Phabricator NUX.Jun 11 2016, 9:03 PM

Merging over into newer task.