Page MenuHomePhabricator

When integrated, CircleCI and Harbormaster can send redundant notifications
Closed, WontfixPublic

Description

Hey guys, I've been in a conversation with zzak from CircleCI because CircleCI sends everyone on my team notifications about every Harbormaster-triggered build failure.

The advice given to me by CircleCI is actually to disable notifications on a per-build basis. Here's a curl request that was provided to be by zzak:

curl --user ${CIRCLE_TOKEN}: --request POST --form revision=${REVISION} --form notify=false https://circleci.com/api/v1.1/project/github/<your-org-id>/<your-project-name>/tree/${BRANCH}

I can't think of a reason why anybody would want both Harbormaster failure notifications as well as CircleCI failure notifications, so I think turning this on for all CircleCI builds triggered from Harbormaster seems reasonable. It looks like HarbormasterCircleCIBuildStepImplementation would be the right place to add this behavior.

Since bug reports MUST include reproduction steps:

Steps to reproduce:

  • I set my notification settings to "branch I've push to fails"
  • A coworker pushes a diff to Phabricator (therefore arcanist triggers a push to a github tag and Harbormaster notifies CircleCI to run build)
  • The build fails

Expected result:

  • I do not receive any notification about the build failure, because I have not pushed to the branch

Actual result:

  • I receive a build failure notification

Extra context: CircleCI seems to be treating all tags as one contiguous branch, which means that we also get misleading "fixed" emails when a completely unrelated commit happens to follow one that doesn't pass the tests.

Version information:

Event Timeline

ry created this task.May 11 2017, 5:49 PM
epriestley added a subscriber: epriestley.

I don't think this is a bug: both systems are behaving as designed.

I can also imagine cases where both notifications are desirable: perhaps the two systems are configured to notify users such that neither set of notified users is a subset of the other. Or users might prefer the CircleCI notifications for whatever reason. And then we're in T8227 territory.

epriestley renamed this task from CircleCI notifications are spammy to When integrated, CircleCI and Harbormaster can send redundant notifications.May 12 2017, 5:35 PM
epriestley triaged this task as Wishlist priority.
epriestley closed this task as Wontfix.Oct 19 2018, 9:27 AM
epriestley claimed this task.

This currently appears to be mooted by T13188.