D14037 had the logic slightly wrong and unit test results are now being double rendered.
- Group Reviewers
- rARCa4dba24c468c: Prevent double rendering of unit test results
Ran a unit test with arc unit -- path/to/test and saw the results rendered only once.
@epriestley's comment shows why shouldEchoTestResults is a bad name for this method. A name like testEngineWillEchoTestResults is also awful, but it better communicates the purpose. The problem is that there is no subject in the name. It would be clearer if the method were rendererShouldEchoTestResults and the logic were inverted.