Page MenuHomePhabricator

ponder (sometimes?) does not send email when an answer is added
Closed, ResolvedPublic

Description

I asked Q103 and it tells me I am 'Automatically Subscribed'. I did not receive an email when an answer (there is only one) was posted.

If I go to /mail, search for mail sent to me and then Control-F for Q103:

  • 52128: The original question
  • 52558: mavit added a subscriber: mavit.
  • 55106: chad closed this question as resolved.

My email settings are to receive everything about Ponder. I also do not see a message about the answer in /notification

Event Timeline

cburroughs updated the task description. (Show Details)
cburroughs added a subscriber: cburroughs.
chad added a subscriber: chad.Aug 26 2015, 7:17 PM

Answer emails start with ANSR

Hmm, also nothing locally or in /mail with ANSR in the subject.

chad added a comment.Aug 26 2015, 7:23 PM

I can't reproduce anything locally, D13951 should have resolved this (and should be on this install).

chad added a comment.Aug 26 2015, 7:25 PM

Will keep an eye out, maybe there is something more specific needed to reproduce it?

chad added a comment.Aug 26 2015, 7:25 PM

Do you seen anything in those emails ^^

chad claimed this task.Aug 29 2015, 9:00 PM
chad added a comment.Sep 2 2015, 12:25 AM

@cburroughs I haven't been able to find any specific repro case here. Do you continue to see issues?

I have not seen this a second time.

chad closed this task as Resolved.Sep 3 2015, 2:58 AM

yay! reopen if you see it again.

I got an email for adding project to Q117, but in my email preferences it's set to "Do not send me an email when I take an action". Is this expected?

The mail is https://secure.phabricator.com/mail/detail/60729/

chad added a comment.Sep 3 2015, 1:53 PM

I can't see that mail page.

chad added a comment.Sep 3 2015, 1:53 PM

Self-Actions is elsewhere in the mail pipeline, it's not a part of any specific application wiring.

OK I created a task and linked it to the Mail project.

sshannin reopened this task as Open.Sep 7 2015, 4:06 PM
sshannin added a subscriber: sshannin.

I believe this occurred to me with Q120.

In the mail page, I see 3 entries for my own actions, but I see no entry for the actual answer that was posted.

chad added a comment.Sep 10 2015, 3:29 PM

I can replicate the core issue, just unclear the correct path to fix as it's involved and a little above my pay grade.

revi added a subscriber: revi.Sep 27 2015, 2:27 AM
chad closed this task as Resolved.Oct 3 2015, 4:38 PM

I believe this is resolved at HEAD. Will keep an eye out for missed cases.