Page MenuHomePhabricator

Impossible to submit "Done" inline comment state without adding a comment
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. open a commit (differential revision) you've made, where somebody else have added an inline comment
  2. check "Done" checkbox on that inline comment
  3. press "Submit" button with "Add Comment" action selection without entering any comment text

Right now nothing happens because comment text is empty. Instead the transaction for marking inline comments Done/Undone should be created regardless of:

  • selected action (Add Comment, Concern Raised, etc.)
  • presence/absence of comment text.

Event Timeline

aik099 created this task.Apr 1 2015, 12:11 PM
aik099 raised the priority of this task from to Needs Triage.
aik099 updated the task description. (Show Details)
aik099 added projects: Differential, Audit.
aik099 added a subscriber: aik099.

Come across this issue and thought the functionality was broken. Should be able to mark done without any comment required.

chad moved this task from Backlog to v2 (UI/Mobile) on the Differential board.Apr 21 2015, 12:25 AM
eadler added a subscriber: eadler.Jun 3 2015, 3:15 PM
angie added a project: Restricted Project.Jun 16 2015, 9:18 PM
angie added subscribers: angie, jhurwitz.
aik099 removed a subscriber: aik099.Jun 17 2015, 7:48 AM
aik099 added a subscriber: aik099.

At HEAD, I get this:

Clicking "Apply Remaining Actions" marks the inline as done. This behavior isn't great, but also isn't "Impossible". Am I doing something wrong (or, uh, not doing something wrong, I guess?)

chad added a subscriber: chad.Sep 10 2015, 12:39 AM
angie closed this task as Resolved.Sep 10 2015, 5:02 PM
angie claimed this task.

Can confirm this now works for me.

angie moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Sep 10 2015, 5:03 PM

We should probably improve this behavior at some point, but it isn't entirely trivial, I'll likely do concurrently with T9132 anyway, and the current behavior is a little rough but doesn't seem too bad (it's inconsistent and needlessly indirect, but not technically incorrect).