Phortune "add payment method" erroring out on submission
Closed, ResolvedPublic

Description

I was just trying to buy you some beer.

yelirekim created this task.Feb 8 2017, 5:10 PM
yelirekim edited the task description. (Show Details)

Edited to not give out my credit card number on the internet.

You destroyed the original file in Files too, right?

This is probably the same as T12158 but I'll merge that here since this is a more complete description.

Yeah I clicked "Delete File" and can't see it anywhere now.

Yeah I clicked "Delete File" and can't see it anywhere now.

😎 πŸ‘ :caprisun: 🌞 πŸ„ 🌊 :sunmbrella: 🍨 🍦 🍧

I'm having some trouble reproducing this -- I tried Safari and Chrome here and in my sandbox. You aren't using anything weird, right?

I think what's happening is that we include Stripe's Javascript with a normal <script /> tag, and then somehow manage to win a race against it and run before it defines the Stripe object, but I'm not sure how that's possible. We can have our behavior sit there waiting for Stripe to become defined, but I'd like to be able to reproduce this and understand what the underlying issue is before we do that.

D17333 is a probable fix without needing to resort to a bunch of weird setInterval() juggling. I've pushed that here, let me know if you're still seeing the issue? If you are, does your JS console have anything in it?

You may want to test the workflow where you give us money several times to make sure it works reliably.

epriestley closed this task as "Resolved".Fri, Apr 7, 12:54 PM
epriestley claimed this task.

While we haven't been showered in free money, I also haven't seen more reports of this so I'm going to presume it's resolved.

yelirekim reopened this task as "Open".Mon, Apr 17, 2:34 PM

Just tried again.

Does this resource load for you?

https://js.stripe.com/v2/

Should look like:

/*! stripe-js 22-03-2017 */
(function(){var a,b,c,d,e,f,g,h,i,j,k,l,m,n={}.hasOwnProperty,...

(Also, do you run some browser extension like "disable all external Javascript so ads don't work"?)

I assume those little icons are "stealthy robot who disables all external Javascript", "Stop external Javascript from working", and "hide my identity from external javascript by preventing it from executing".

Maybe a simpler empirical test is, on the "Add Payment Method" page, does this work in the developer console?

Stripe

No nothing like that but FWIW, it just worked when I tried to reproduce it again.

epriestley closed this task as "Resolved".Mon, Apr 17, 2:44 PM

Alright, I'm going to assume this was cache/ghosts until it happens to someone else since it seems like no reproduction case exists anywhere anymore.

Yeah I just wanted to buy myself a badge.

You are now officially Pay2Win.