Page MenuHomePhabricator

owners packages details screen throws exception
Closed, InvalidPublic

Description

https://phabricatorinstance/owners/package/1/

Bad getter call: getDominion
Stack trace:
LiskDAO::call called at [/opt/phabricator/phabricator/src/infrastructure/storage/lisk/LiskDAO.php:1678]
PhabricatorOwnersPackage::getDominion called at [/opt/phabricator/phabricator/src/applications/owners/controller/PhabricatorOwnersDetailController.php:188]
PhabricatorOwnersDetailController::buildPackageDetailView called at [/opt/phabricator/phabricator/src/applications/owners/controller/PhabricatorOwnersDetailController.php:47]
PhabricatorOwnersDetailController::handleRequest called at [/opt/phabricator/phabricator/src/aphront/configuration/AphrontApplicationConfiguration.php:237]
phlog called at [/opt/phabricator/phabricator/src/aphront/handler/PhabricatorDefaultRequestExceptionHandler.php:32]
PhabricatorDefaultRequestExceptionHandler::handleRequestException called at [/opt/phabricator/phabricator/src/aphront/configuration/AphrontApplicationConfiguration.php:644]
AphrontApplicationConfiguration::handleException called at [/opt/phabricator/phabricator/src/aphront/configuration/AphrontApplicationConfiguration.php:242]
AphrontApplicationConfiguration::processRequest called at [/opt/phabricator/phabricator/src/aphront/configuration/AphrontApplicationConfiguration.php:149]
AphrontApplicationConfiguration::runHTTPRequest called at [/opt/phabricator/phabricator/webroot/index.php:17]

owners package was created with Phabricator dc2d87059b29b9dfe8838c2e0b07f4074f599112, libphutil b25e0477b280ca3e8345bb97cd55e95bcb5023ec

now running phabricator 804a5db41a9a874d8d323118a578e1cfbf0b6fb0, libphutil bd56873ae4c0f77d1fabc66289b62dfaa2ca56b5

Event Timeline

Did you fully restart everything (see Restarting Phabricator) after upgrading? I can't reproduce this and it looks like the kind of thing that could happen if Phabricator was not fully restarted.

For example, packages on this install work properly for me and show their "Dominion" setting:

https://secure.phabricator.com/owners/package/10/

...and the property exists:

https://secure.phabricator.com/diffusion/P/browse/master/src/applications/owners/storage/PhabricatorOwnersPackage.php;3d3fff4991ab921853fd0d1fc96f8b1e65b962d7$24

avivey added a subscriber: avivey.May 23 2016, 12:17 AM

Did you restart all webservers/php-fpm/etc. after upgrading? Did you upgrade the storage?
I cannot immediately reproduce this - see Contributing Bug Reports for some more information that can help you.

allixsenos closed this task as Invalid.May 23 2016, 9:13 AM

I apologize, my ansible deploy script *should* have restarted everything that needs restarting, but it appears it didn't.