Ref T12631. Let unit test actually test ArcanistLinterStandard.
LGTM. @epriestley, it would be greatly appreciated if this could be accepted upstream. We have a large number of XHPAST linter rules (I think ~200) and we want to write integration tests to ensure that they play nicely together.
You should extend ArcanistLinterTestCase instead
You might want to leave this.
Maybe call this getBaseLinter?
I think this should be called getStandard
Ideally, we should have some sort of $linter->applyStandard($standard) method... because this code is currently duplicated from ArcanistLinter