Page MenuHomePhabricator

Phabricator fails with a fatal PHP error if it receives a mail with no plain text part
Closed, ResolvedPublic

Description

Send a mail to Phabricator with no plain text part (HTML only) and a PHP fatal error occurs.

phabricator
    8f7983a5be3a56db5b79dc7c3a0eb470f1d7ca02 (Sat, Mar 25) (branched from b4effdf26c3e7d5de0d010cf14626c5d8d404e04 on origin) 
arcanist
    60aaee0ed3f5a1e4384ac7d7f2efd2c64cecbe44 (Sat, Mar 25) (branched from d1db9a72b552151613a918e3d49fa72433387a68 on origin) 
phutil
    b133c277014868d476f08b4ebecde2ea795509e4 (Sat, Mar 25) (branched from c0bc116bedc895fd617799a13549f8707edfd3fb on origin)

Event Timeline

isfs created this task.Apr 23 2017, 4:27 PM
epriestley closed this task as Resolved.Feb 1 2018, 10:54 PM
epriestley claimed this task.
epriestley added a subscriber: epriestley.

I can't reproduce this; it may have been fixed by D18776 + D18778.