Page MenuHomePhabricator

Panel positioning improvements
Closed, InvalidPublic

Description

On large dashboards it is difficult to move around panels with the drag&drop technique.

Would be nice to have an alternative "more robust" way to do it.

An example would be to have four arrows near the already added "remove panel" and "edit properties" that move the panel in the appropriate direction if pressed (jumping one panel at a time if vertical direction and one column at a time if horizontal).

Event Timeline

stevex created this task.Oct 20 2016, 4:46 PM
stevex updated the task description. (Show Details)Oct 20 2016, 4:46 PM
epriestley closed this task as Invalid.Oct 20 2016, 4:51 PM
epriestley added a subscriber: epriestley.

even sometime seems to me not properly working

If this isn't working properly, please file a bug report with complete reproduction steps we can use to reproduce the issue. See Contributing Bug Reports.

stevex updated the task description. (Show Details)Oct 20 2016, 4:54 PM

even sometime seems to me not properly working

If this isn't working properly, please file a bug report with complete reproduction steps we can use to reproduce the issue. See Contributing Bug Reports.

I removed the part of not working properly, since as you reported I should make a better reproduction description.

I left the rest of feature request.

I don't plan to implement the rest of the feature request. Assuming drag and drop works correctly, I think this operation (reordering panels) is rare enough that using it is reasonable without introducing the additional complexity of duplicate controls.

Among other issues, arrows are, e.g., ambiguous in this case:

...
|          |   |   B    |
+----------+   +--------+
+----------+  
|    A     |   +--------+
|          |   |   C    |
|          |   +--------+
+----------+
+----------+   +--------+
|          |   |   D    |
...

If you click "Move Right" on "Panel A", does it move between panels B and C or between panels C and D?

Issues like this would be more complex on more complex layouts, particularly if we introduce additional layouts in the future (see T6444).

stevex added a comment.EditedOct 20 2016, 5:16 PM

Among other issues, arrows are, e.g., ambiguous in this case:

...
|          |   |   B    |
+----------+   +--------+
+----------+  
|    A     |   +--------+
|          |   |   C    |
|          |   +--------+
+----------+
+----------+   +--------+
|          |   |   D    |
...

If you click "Move Right" on "Panel A", does it move between panels B and C or between panels C and D?

For me would not make any difference, since with another simply up or down will (reliably) soIve the problem.

Moreover most probably when I change the column (as I was) I would position it even more differently (requiring more ups or downs).