Page MenuHomePhabricator

Dashboard drag and drop a test in patience
Closed, InvalidPublic

Description

Steps:

  1. open dashboard
  2. You might have the for example 3 tables already
  3. Add 2 more
  4. Change the places of the panels within the dashboard.
  1. Problem is it hard to change places, for example if I want to mode the middle table to up it is not possible. if there are for example a panel with tabs,

If i want to move that normal panel between those those panel with tabs, it is not possible. Why?

Normal panel (this can not be moved)

Panel with tabs

(to here)

Panel with tabs

  1. with some boards you can move the panels but after I save the panel is like it was before changes.

I think those should be really dynamic, like that I could move the panels to up, left, or down or between the panel with tabs.

Version:
phabricator 51f8ec4487be02e290b1182a7cd5b4069fe7d49f (Tue, Sep 20) arcanist 9e82ef979e8148c43b9b8439025d505b1219e213 (Thu, Aug 25) phutil fa6519f4cea1c059bd381c20971cac413cc4760e (Thu, Sep 15)

Event Timeline

chad renamed this task from Dashboard modification when changing query table does not work to Dashboard drag and drop a test in patience.Sep 28 2016, 7:37 PM
chad added a project: Dashboards.
eadler added a project: Restricted Project.Sep 29 2016, 6:29 PM

I wasn't actually able to reproduce this -- were you, @chad?

chad added a comment.Oct 20 2016, 5:00 PM

It's always felt like 10% unpredictable to me, but I haven't tried it in a while.

epriestley closed this task as Invalid.Oct 20 2016, 5:02 PM

It should show a pretty clear preview of what it's going to do before you drop, so I'm not sure how it could be unpredictable? I wasn't able to identify any weird/surprising behavior when I tried to reproduce this.

There are quite possibly improvements we can make here, but we need detailed reproduction steps which allow us to reproduce and observe issues before we can fix them. I'm unable to reproduce this issue by following the provided steps.

stevex added a subscriber: stevex.Oct 20 2016, 5:23 PM
In T11669#197945, @chad wrote:

It's always felt like 10% unpredictable to me, but I haven't tried it in a while.

I also have this "filmsy" feeling using it and for this reason I suggested the T11775: Panel positioning improvements