Page MenuHomePhabricator

No queries available on Dashboard exception.
Closed, InvalidPublic

Description

  • Pick a dashboard, go to "Manage Dashboard".
  • Create Panel -> Query Panel
  • Assign any name, pick any query -> Create Panel.
  • Either edit the recently created panel, or try to add a new one
  • Query dropdown only shows "none" as an option. Previous options are non existant.
  • Confirming will result in the panel showing "Exception: Query "" is unknown to application search engine "PhabricatorPeopleLogSearchEngine"!

Versions
phabricator

b3dd0fd860380854a25ec8c6f24a23dc6b0a7837 (Sat, Feb 6)

arcanist

0553cb8d411817bcc40bd484ed8e209f4b870ff7 (Fri, Jan 29)

phutil

9c472e7c9b64395424c6cd25734bf239cb3c113d (Sat, Jan 23)

Event Timeline

phabricator a45fe337a12f29efdf425086018f1160906f0d0f (Sun, Feb 7)
arcanist 57f6fb59d73994d90cd94143787424ce0fdbf73b (Mon, Jan 25)
phutil f43291e99d36045bc459e5133454c0d8fd8768ea (Thu, Jan 21)

I cannot repro on my instance.

chad added a subscriber: chad.Feb 8 2016, 3:10 PM

I can't repro on any of these steps. Can you give us more specific details maybe that we're missing. Sounds like Javascript didn't fire or something for you. Can you reproduce on this install?

Ok, checking Firefox's error console and I get
Error: JX.initBehavior(map): behavior(s) not registered: dashboard-query-panel-select
Expanded to reveal:

JX.$E()                                              core.pkg.js:2
JX.initBehaviors()                                   core.pkg.js:178
.members._handleResponse/when_complete<()            core.pkg.js:235
.statics._complete()                                 core.pkg.js:193
.statics._loadJS/load_callback()                     core.pkg.js:184

Can't reproduce on this install, though.

chad added a comment.Feb 8 2016, 5:42 PM

This generally points to something environmental on your install. Did you restart the webserver / apache after upgrading? Any proxies or other resource caching going on like cloudflare?

oysterFAKE added a comment.EditedFeb 8 2016, 5:44 PM

No cloudflare or caching.
Did restart the server after upgrade.
Issue began to happen following upgrade + restart on Saturday 30th January.

Is there any data I should be pulling to help diagnose?

EDIT: january, not november

chad added a comment.Feb 8 2016, 8:34 PM

I don't have any ideas on how to troubleshoot this, since it's most likely to be between the webserver and your browser and I've never run into it personally.

Phabricator uses "Celerity" to manage packaging. If we change any CSS/JS/Image, we run bin/celerity map to generate a new static package. When you update Phabricator, in most cases you also get a new package (with a unique hash). This prevents caching of old resources and causing issues.

Maybe an app like Charles could help debug further? https://www.charlesproxy.com/

epriestley closed this task as Invalid.Feb 29 2016, 12:43 AM
epriestley added a subscriber: epriestley.

It seems like this isn't reproducible in other environments. Feel free to file a new report if you are able to uncover more information in the future.