Page MenuHomePhabricator

Rename "PhabricatorHash::digest()" to "weakDigest()"
ClosedPublic

Authored by epriestley on Apr 6 2017, 5:10 PM.
Tags
None
Referenced Files
F15468283: D17632.id.diff
Thu, Apr 3, 10:48 PM
F15461781: D17632.id42403.diff
Tue, Apr 1, 11:14 AM
F15455510: D17632.id42403.diff
Sun, Mar 30, 2:23 AM
F15454223: D17632.diff
Sat, Mar 29, 5:04 PM
F15441025: D17632.diff
Wed, Mar 26, 4:06 PM
F15430037: D17632.id42417.diff
Mon, Mar 24, 5:23 AM
F15409247: D17632.id42403.diff
Wed, Mar 19, 3:47 AM
F15409246: D17632.id42417.diff
Wed, Mar 19, 3:47 AM
Subscribers
None

Details

Summary

Ref T12509. This encourages code to move away from HMAC+SHA1 by making the method name more obviously undesirable.

Test Plan

grep, browsed around.

Diff Detail

Repository
rP Phabricator
Lint
Lint Not Applicable
Unit
Tests Not Applicable

Event Timeline

This revision is now accepted and ready to land.Apr 6 2017, 6:22 PM
This revision was automatically updated to reflect the committed changes.