I've been thinking about this for a while... why not just fold ArcanistPhutilXHPASTLinter into ArcanistXHPASTLinter?
Details
Details
- Reviewers
epriestley - Group Reviewers
Blessed Reviewers - Commits
- rARC9dd6eafb5254: Fold `ArcanistPhutilXHPASTLinter` into `ArcanistXHPASTLinter`
arc unit
Diff Detail
Diff Detail
- Repository
- rARC Arcanist
- Branch
- master
- Lint
Lint Passed Severity Location Code Message Advice src/lint/linter/xhpast/rules/ArcanistClassExtendsObjectXHPASTLinterRule.php:20 XHP16 TODO Comment - Unit
Test Failures - Build Status
Buildable 8803 Build 10266: Run Core Tests Build 10265: arc lint + arc unit
Event Timeline
Comment Actions
I don't like that third parties who are developing things like Phabricator applications and arc extensions need to maintain a list of un-disables on these rules. There's no way for them to keep this list in sync with the "correct" list in the upstream.
Comment Actions
One possibility that I was considering was to introduce an xhpast.standard which can be phutil or psr-2 (see D13512 for another use case).
Alternatively, we could do something like this:
public function getLintSeverity() { if ($this->isPhutilLibrary()) { return ArcanistLintSeverity::SEVERITY_ADVICE; } return ArcanistLintSeverity::SEVERITY_DISABLED; }
Comment Actions
I think I like the "standard" approach. The other one feels maybe a little too magical to me.