Page MenuHomePhabricator

When packages are archived, packages shouldn't be listed as auditor
Closed, ResolvedPublic

Description

steps to reproduce

  1. Make a Diffusion repo, and an Owners package.
  2. Enable auditing.
  3. Make a few commits.
  4. Now, archive the package.

Expected behaviors

When new commit is pushed, package is not shown as auditor.

what I see

Package is still added as an auditor.


I tried disabling auditing, but it is still listing package as auditor.

Event Timeline

revi created this task.Oct 1 2015, 11:30 AM
revi updated the task description. (Show Details)
revi added a project: Owners.
revi added a subscriber: revi.
cburroughs added a project: Restricted Project.Apr 20 2016, 3:32 PM
cburroughs moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Apr 20 2016, 3:57 PM
epriestley closed this task as Resolved.May 14 2016, 12:36 AM
epriestley claimed this task.

Archived packages are no longer added as auditors to new commits after D15907 by the "Auditing Enabled" setting.

Existing commits which already had audits triggered will retain their audit status. This is by design, and consistent with other objects (disabling a user or project doesn't remove them as an auditor, reviewer, or subscriber from objects, for example).