Page MenuHomePhabricator

Copied code detection takes >30s on 48MB diff
Closed, ResolvedPublic

Description

One of @nickz's users arc diff'd a 48MB change (1.1 million lines of translation strings) that fails out in detectCopiedCode() after hitting the 30s time limit.

We should improve this failure mode and/or the relevant warnings.

See also T6766.

Event Timeline

epriestley raised the priority of this task from to Normal.
epriestley updated the task description. (Show Details)
epriestley added a project: Differential.
epriestley added subscribers: epriestley, nickz.
epriestley closed this task as Resolved.Feb 20 2019, 2:52 PM
epriestley claimed this task.

Presuming resolved by D19748 since we don't have an actual reproduction case.