Page MenuHomePhabricator

Commit was associated with unrelated diff
Closed, InvalidPublic

Description

Someone reported this to me on our install... It seems that a commit has associated with a revision which is seemingly unrelated. The commit message is as follows:

Revert "REDACTED"

This reverts commit d7038b5ea06e1818f5651a8bfcf6e61009f1f198.

In the transaction history for this commit, I see the following items:

  • alincoln committed rPPfd5a74ad3fa1: Revert "REDACTED" (authored by alincoln). Via Daemons · Fri, May 1, 3:52 AM
  • alincoln added a reverting commit: rPPd7038b5ea06e: REDACTED

In the transaction history for the diff, I see the following:

  • bob added a task: T23545: REDACTED Via Conduit · Thu, Apr 30, 5:53 PM
  • bob created this revision.
  • bob added reviewers: alice.
  • bob added a dependency: D19838: REDACTED
  • alice accepted this revision. Via Web · Thu, Apr 30, 5:57 PM
  • This revision is now accepted and ready to land.Via Web · Thu, Apr 30, 5:57 PM
  • Closed by commit rPP89c027fc6410: REDACTED (authored by bob). · Explain Why Via Daemons · Thu, Apr 30, 6:00 PM
  • This revision was automatically updated to reflect the committed changes

Event Timeline

joshuaspence added a subscriber: joshuaspence.
joshuaspence created this task.
joshuaspence raised the priority of this task from to Needs Triage.

Does clicking "Explain Why" explain why?

There is no relevant "explain why" link because there is no transaction for someone added a commit: rPPfd5a74ad3fa1 on D19839 or someone added a differential revision: D19839 on rPPfd5a74ad3fa1.

This happened again today (for my own future reference, see D20770 on our install).

This happened again today. I ran for REPO in $(./bin/repository list); do ./bin/repository reparse --message $REPO; done and a whole lot of badness ensued.

This is interesting. We had an abandoned diff which got closed by ./bin/repository reparse. If I click on "Explain Why" then it says We didn't find a "Differential Revision" field in the commit message. That doesn't really make sense to me, is this a bug?

eadler added a project: Restricted Project.Jan 8 2016, 11:09 PM
eadler moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Jan 8 2016, 11:11 PM
eadler removed a project: Restricted Project.Apr 7 2016, 6:37 PM
epriestley moved this task from Backlog to Triage on the Diffusion board.Feb 2 2017, 4:08 PM
epriestley closed this task as Invalid.Apr 15 2019, 4:12 PM

No idea how to reproduce this.