Page MenuHomePhabricator

Unhandled Exception ("AphrontQueryException")
Closed, ResolvedPublic

Description

Maniphest -> Create task

After Save

Unhandled Exception ("AphrontQueryException")
#1265: Data truncated for column 'duration' at row 1

php -v
PHP 5.3.10-1ubuntu3.13 with Suhosin-Patch (cli) (built: Jul 7 2014 18:54:55)
mysql -V
mysql Ver 15.1 Distrib 10.0.12-MariaDB, for debian-linux-gnu (x86_64) using readline 5.1

Event Timeline

trubachoff raised the priority of this task from to Normal.
trubachoff updated the task description. (Show Details)
trubachoff added projects: Maniphest, Aphront.
trubachoff added a subscriber: trubachoff.
btrahan added a subscriber: btrahan.Aug 7 2014, 8:05 PM

Can you reproduce this on this instance? I can't -- T5820 for example.

What is "duration"? Is that some sort of custom field on your instance? Have you configured it properly?

trubachoff added a comment.EditedAug 8 2014, 1:42 PM

I used default installation Phabricator from github.
I found 'duration' in "herald_transcript", "worker_archivetask", "conduit_methodcalllog", "harbormaster_buildlog" tables.
Can you sign in http:/phabricator.dealerpoint.ru/ for see this bug when creating a new task in Maniphest?

Can you show us the output of this command?

phabricator/ $ ./bin/storage upgrade
In T5816#7, @epriestley wrote:

Can you show us the output of this command?

phabricator/ $ ./bin/storage upgrade

`$ ./bin/storage upgrade
Before running storage upgrades, you should take down the Phabricator web
interface and stop any running Phabricator daemons (you can disable this
warning with --force).

Are you ready to continue? [y/N] y

Storage is up to date. Use 'storage status' for details.`

trubachoff closed this task as Resolved.Aug 13 2014, 12:42 PM
trubachoff claimed this task.

I'm change phabricator/.devinercache owner
and exception don't appear.

PS also i reboot server

The real root cause of this issue may have been a locale setting which uses comma as a decimal separator, see T7339.