Page MenuHomePhabricator

Query: Active Repository shows wrong HEAD commit
Closed, InvalidPublic

Description

When I check it from https://my.install/diffusion/, it shows not-HEAD commits on the page.

When I check the Repository, I can see commit history like

a4349fb857cf	YongJoon	Fix Test mode		10:30 AM
abdd99c86817	YongJoon	Better result printing	10:30 AM
0dc4027d0d1a	YongJoon	Fix Show Question	10:30 AM
ae03a0ac373a	YongJoon	Better showing for ...	10:14 AM
030075a6e263	YongJoon	Fix `checkCU` with ...	May 16
b1c6c1aca4da	YongJoon	Fix `notCover`		May 16
....

But the commit under the repository's title on https://my.install/diffusion/ shows second commit abdd99c86817 Better....

On the page of https://my.install/source/THEREPOSITORY/ also show right commits.

In the repository structure view, Detail of src/ directory shows a4349fb857cf Fix Test mode, not abdd99c86817 Better..., and master branch also shows proper commit.

Their actual commit timestamp(Phabricator may describe this as Authored time) are:

  • Wed, May 17, 10:26 AM. for a4349fb857cf
  • Wed, May 17, 10:24 AM. for abdd99c86817

This can be confirmed from git and each commit page of Diffusion.

I'm not sure that this is a bug or not, but is a very confusing feature.

Reproduction step

I'm sorry. This is a productive environment, so I could not test to reproduce it and I don't know how can I reproduce it.

But I assume that this caused because of

  1. The hash value of the second commit is bigger than the first(HEAD) commit.
  1. They have same committed timestamp (not by git, but by Phabricator) because the phd daemon was not loaded when I pushed the three commits and the commits are synced at once after I start the daemon. (I realized that because the commits are not shown on the history.)

Version Information

phabricator e4e91ebf6f15936a90ab7fff4e249b3fb6dd0058 (Wed, May 17)
arcanist 3c4735795a2963c5ddff6dceaf60122d01ca3dc0 (Wed, May 3)
phutil a900d7b63e954e221efe140f0f33d3d701524aae (Mon, Apr 24)

Event Timeline

QuietJoon updated the task description. (Show Details)
QuietJoon updated the task description. (Show Details)May 17 2017, 7:21 AM
QuietJoon updated the task description. (Show Details)
epriestley closed this task as Invalid.May 17 2017, 11:02 AM
epriestley added a subscriber: epriestley.

This is a productive environment, so I could not test to reproduce it and I don't know how can I reproduce it.

Sorry, we can't move forward without reproduction instructions. If this wasn't clear from Contributing Bug Reports, let us know how we could make it more clear. Thanks!