Page MenuHomePhabricator

Make Phriction ToC more structured
Closed, DuplicatePublic

Description

Phriction articles can have many headers of different depths. Nested instructions and contents are part of most use cases of Phriction. But the auto generated table of contents is a flat list. If you have three depths of headers, they all seem alike in the ToC. That is a big problem in finding the right spot in a big Phriction article. The usefulness of the ToC is decreasing fast if you have more than 10 headers with 2 or 3 different depths.

The ToC should be more structured and clearly arranged. The ToC should be automatically numbered and indented with every new header depth (like the ToC of Wikipedia).

Event Timeline

benwick created this task.Apr 21 2017, 9:15 AM
benwick updated the task description. (Show Details)
ivo added a subscriber: ivo.Apr 21 2017, 12:15 PM
chad added a subscriber: chad.Apr 21 2017, 2:17 PM

We already have a path forward on the next iteration of Phriction, and it doesn't include this direction. Please read Contributing Feature Requests and Describing Root Problems if you have future feature suggestions, root problems are required for any request filed. Thanks!

chad closed this task as a duplicate of T9379: Build Phriction v3.Apr 21 2017, 2:17 PM

It does include this direction (T9868), so I'm looking forward to this.

The root problem is clear: The ToC is useless in a highly hierarchical Phriction article with many nested headers.

chad added a comment.Apr 21 2017, 4:23 PM

We don't consider that to a be a root problem.

chad added a comment.Apr 21 2017, 4:36 PM

The ToC is a currently a bandaid to a design problem, that people put too much information into a single page due to lack of alternative choices. Our solution moving forward isn't to just improve the ToC, but to improve Phriction overall and allow more CMS level customization (like a permanent sidenav). Knowing why so much information is placed on a page is the root problem we're looking for. If we just improve the ToC, I don't feel we're solved the root problem.

You may be right, that the root problem is people putting to much content in Phriction articles. But even a need content seperation like this one

Installation

Step 1

Step 2

Setup

Step 1

Step 2

would greatly improve with a structured ToC like that

1. Installation
  1.1 Step 1
  1.2 Step 2
2. Setup
  2.1 Step 1
  2.2 Step 2

But looking forward to your solutions!