Page MenuHomePhabricator

Unable to create differential
Closed, InvalidPublic

Description

Following is the stack trace while doing arc diff

[2017-04-18 12:13:03] EXCEPTION: (PhutilAggregateException) Some linters failed:

  • PhutilProxyException: JSHint returned unparseable output. at [<arcanist>/src/lint/engine/ArcanistLintEngine.php:274]

arcanist(head=master, ref.master=a59cfca5f190), phutil(head=master, ref.master=6fe33623cda6)

#0 <#3> PhutilJSONParser::parse(string) called at [<phutil>/src/utils/utils.php:1154]
#1 <#3> phutil_json_decode(string) called at [<arcanist>/src/lint/linter/ArcanistJSHintLinter.php:119]
#2 <#2> ArcanistJSHintLinter::parseLinterOutput(string, integer, string, string) called at [<arcanist>/src/lint/linter/ArcanistExternalLinter.php:437]
#3 <#2> ArcanistExternalLinter::resolveFuture(string, ExecFuture) called at [<arcanist>/src/lint/linter/ArcanistFutureLinter.php:34]
#4 <#2> ArcanistFutureLinter::didLintPaths(array) called at [<arcanist>/src/lint/engine/ArcanistLintEngine.php:605]
#5 <#2> ArcanistLintEngine::executeDidLintOnPaths(ArcanistJSHintLinter, array) called at [<arcanist>/src/lint/engine/ArcanistLintEngine.php:556]
#6 <#2> ArcanistLintEngine::executeLintersOnChunk(array, array) called at [<arcanist>/src/lint/engine/ArcanistLintEngine.php:484]
#7 <#2> ArcanistLintEngine::executeLinters(array) called at [<arcanist>/src/lint/engine/ArcanistLintEngine.php:216]
#8 ArcanistLintEngine::run() called at [<arcanist>/src/workflow/ArcanistLintWorkflow.php:334]
#9 ArcanistLintWorkflow::run() called at [<arcanist>/scripts/arcanist.php:394]

<<< [17] <exec> 371,116 us

Event Timeline

my .arclint file

{

"linters": {
  "jshint": {
    "type": "jshint",
    "jshint.jshintrc":".jshintrc",
    "include": "(\\.js$)"
  },
  "json":{
    "type": "json",
    "include": "(\\.json$)"
  }
}

}

This is happening because my project directory not contains .jshintrc file

epriestley closed this task as Invalid.Apr 18 2017, 1:44 PM
epriestley added a subscriber: epriestley.

Bug reports require reproduction steps. See Contributing Bug Reports and Providing Reproduction Steps.