Page MenuHomePhabricator

db schema error
Closed, InvalidPublic

Description

While upgrading phabricator, there is a schema error with the db.
Verifying database schemata on "localhost:3306"...
Found no adjustments for schemata.

Target Error
phabricator_differential.differential_revision.properties Wrong Nullable Setting
Find attached screen shots

Event Timeline

epriestley added a subscriber: epriestley.

If you believe you've found a bug in Phabricator, we need all the information discussed in Contributing Bug Reports to move forward. Specifically:

See Support Resources for other ways to get help if you can't provide this information.

@epristley

Please find the image with upgrade branch. While upgrading the phabricator from this branch we found this error. Please check this upgrade to reproduce the error.

chad added a subscriber: chad.Mar 29 2017, 5:43 AM

We don't accept bug reports without reproduction steps.

@chad you need to try upgrade phabricator from branch abff6dc8a9b4e081d74beaf8f062223cb5308ec3 to reproduce the issue. Can you consider this as step to reproduce the error.

chad added a comment.Mar 29 2017, 5:49 AM

If you believe those are the full, complete steps to reproduce the issue then please take the time and launch a clean test environment and follow the steps and let us know if they are complete.

chad added a comment.Mar 29 2017, 6:00 AM

My only guess here is something is corrupt, incomplete, or not upgraded properly. I don't see anything on our side that would lead to this state.

@chad -we tried the upgrade once again .. but the issue is still there

@dainysunil you need to provide full instructions to reproduce this issue in an untainted environment.

You're referring to your local environment where the upgrade fails, but as long as there's no way for the Phacility team to reproduce this issue in a generic environment there's no way to further investigate and possibly fix it.

epriestley closed this task as Invalid.Apr 7 2017, 12:39 PM

We don't know how to reproduce this.