Page MenuHomePhabricator

differential.query by commitHash only searches the latest commit hashes
Closed, InvalidPublic

Description

given the title, check out this screenshot

http://dl.dropbox.com/u/21786/commits.png

and know that only the last commit hash finds the pertinent revision. any commit hash should find the pertinent revision.

(...this is part of a big ball of wax IMO like T201 and T1083 and I kind of forgot the big picture plan to fix all this... :/ )

this commit hash thing breaks workflows for @aurelijus and friends. (there's some conversation in IRC around this at the bottom-ish of this page -- https://secure.phabricator.com/chatlog/channel/%23phabricator/?offset=10000)

Event Timeline

btrahan added a project: Differential.
btrahan added subscribers: btrahan, aurelijus, epriestley.

BTW, we need a permanent link instead of /chatlog/channel/%23phabricator/?offset=10000. It can be done using PhabricatorIDPagedPolicyQuery.

vrana added a subscriber: vrana.May 16 2012, 11:47 PM

yeah chatlog is awful to the max

Specifically, there are two issues here:

  • We search only by most recent diff. This probably isn't a big deal -- it might be nice to search by older diffs, but this is a rare use case.
  • We search only by attached diffs, not attached commits. It sounds like this is the main issue @aurelijus is hitting.
epriestley triaged this task as Normal priority.May 30 2012, 2:31 PM
btrahan added a project: Differential.
chad changed the visibility from "All Users" to "Public (No Login Required)".Jul 3 2015, 4:36 AM
epriestley closed this task as Invalid.Jan 1 2017, 5:27 PM

This is older than time itself and does not meet the modern standards for a feature request. In particular, I have no idea what problem it was intended to resolve and nothing that has been linked here in the last couple of years gives me much of an idea. There are likely better approaches in a modern context (T5873, T3875 + T11355, maybe?). If you want this for some purpose, feel free to file a new request describing your problem in better detail. T11355 is probably the most relevant?