Add custom fields to the "Task Action..." menu
Closed, InvalidPublic

Description

The value of the custom fields created cannot be modified in the "Task Action..." menu.

Would be faster and easier for the user to change the value directly from there.

I have a custom field called "Percent done" (percent of the task done). The programmer fills the progress of the task from "Task Action..." menu and then he needs to go to edit the task and change the percent field there.

Would be great to have all the custom fields there or maybe better to define a new attribute to add the custom field to the "Task Action..." or not (like the search attribute).

The information provided in this feature request doesn't provide the upstream with enough information to move forward. Please read Contributing Feature Requests and Describing Root Problems carefully and be sure follow all required steps before filing a task. We always require a root problem with every task.

Sorry I'll try to describe the problem better.

The problem is that I have created a custom field and it's value cannot be modified during the task progress using the "Add Action..." menu:

You need to go to "Edit task" to modify that particular field (the standard fields can be modified easily by using that "Add Action" menu)

Have you read the articles I linked?

Sure I read them before posting anything!. Sorry I can't see what's wrong?

You have yet to provide a root problem

The root problem is that I have created a custom field and I cannot modify it's value from the "Add Action" menu.

As I said before it's a custom field to fill the task progress and I cannot modify that progress using the "Add Action..." menu

See Describing Root Problems if you need help defining the root problem. We don't take "feature does not exist" as a reason to build something.

OK, I understand, I tried it several times... thanks for your time.

I think T4316 is probably the best solution here, without knowing more about your user's workflow.

Not really.

OK, our workflow is the following:

  • When a developer gets a task assigned he opens it and start doing the task
  • From there, he always do all task changes by using the famous "Add Action...".
  • Everyday he writes down in the comment area the task progress AND he has to update a custom field called "Percent" which is a select custom field with the options "0%, 25%, 50%, 75%, 100%". THE PROBLEM is that he cannot change that custom field value by using the "Add Action...". He needs to go to "Edit Task" and of course that change isn't reflected in the task timeline.

That's why my request is to allow to add custom fields to the "Add Action..." menu.

I suppose most of the people using custom fields would like to have that option!!! For example in my case: Add Action->Change Percent

  • Why do you track "percent complete"? What do you use it for?
  • Is it actually accurate? Developers are notoriously bad at estimating project timelines, so I would naively guess that a "Percent" field would have almost no relationship to reality.

Hi Evan,

Well, as you said, it depends a lot on the programmer, yes. But like any other project management tool, I think it's not so important how accurate it is. The important thing for me is to have a an idea on how is going the task.

We also use a time estimation field. The idea is that the programmer itself (when it gets a task assigned) must think first and try to guess how much time to finish it. And everyday he has to fill the estimated time left.

Of course, it depends also a lot on the kind of task. When it is a task similar to other done in the past, it is usually very accurate. If it is an investigation task, it is probably less useful.

epriestley closed this task as "Invalid".Sat, Feb 18, 2:36 AM

Unfortunately, this doesn't seem to be moving toward an upstreamable feature request which completely describes a root problem. I'm not sure how we can make what we're asking for more clear. We've already spent a significant amount of time on this and need to move on to other things.

sergio.castro added a comment.EditedMon, Feb 20, 9:42 AM

Can I make a question?

Why do you restrict the options in the "Add Action..." dropbox? If a task have, let's say, 10 fields, why don't you allow the user to change all those 10 fields? In the end, that's the question.

As I said to your colleague before, I think you are more worried about your feature/bug posting rules and your "root problems" than to try to understand your real user's problems (like me). I can understand you have a lot of work and maybe the feature I'm asking for can be in the backlog for months/years, but I cannot understand to close it as invalid. It is a real problem I have and I am completely sure more people will have the same problem.

Regarding to my workflow and my specific needs with this custom field called "Percent Complete", ALL, and believe me when I say ALL the well known bug tracking and project tracking software around the world (commercial and opensource) have fields to define the progress of the task and usually more things like "Time spent" and so on...

So, believe me, this is not a very strange thing I have, the strange thing is that you doesn't have that field by default in your product and much more strange to close this task as invalid.

I have also spent a significant amount of time trying to explain my problem (and this is not my bussiness!).

Anyway, as I told to your colleague, thanks for your time and don't worry I won't bother you again. I will try to add this feature myself (thanksfully it's opensource) and in the future I'll do the same when I have a problem with your product.