Tag task with a Project and Subproject
Closed, InvalidPublic

Description

Hello,

When tagging a Task with a Project and one of its Subproject, only the Subproject is kept. The expected behavior is to have both projects in the Tags.

Reproduce:

  • Create a new Task
  • Add the Project in Tags
  • Add on of Project's Subproject in the Tags
  • Create the task
  • Observe the Tags list

We're using those versions:
phabricator 1cd64f9975d66a5fff516cd064cd076b0eb7b07f (Dec 16 2016)
arcanist e17fe43ca3fe6dc6dd0b5ce056f56310ea1d3d51 (Oct 22 2016)
phutil 0ae0cc00acb1413c22bfe3384fd6086ade4cc206 (Dec 10 2016)

Cheers

aubort created this task.Jan 23 2017, 1:03 PM

This is documented in the userguide.

https://secure.phabricator.com/book/phabricator/article/projects/

Objects may not be tagged with multiple projects that are ancestors or descendants of one another. For example, a task may not be tagged with both Stonework and Stonework → Masonry.

Good catch ! This is a disturbing behavior for the end user though.

epriestley closed this task as Invalid.Jan 23 2017, 3:08 PM
epriestley added a subscriber: epriestley.

This is by design, and explained in the documentation.

Actually there's a bug with this behavior in the workboard, I can reproduce that in a test instance in phacility as well.

Reproduce:

  • Create a new Project test-main
  • Create a Subproject test-child
  • Go to test-main and create a workboard
  • From the backlog -> create task
    • set title: temp2 the tags already shows test-main
    • add tag: test-child
    • Click Create New Task
  • There's now a grayed out page, the task is not created

The expected behavior is to have the test-main tag removed in favor of test-child

Should I open a new bug ?

Regards

Should I open a new bug?

Yes.

In general, if you're ever unsure, please open a new task rather than commenting on an existing task. It's very easy for us to merge tasks if they're really the same issue (click one button) but it isn't nearly as easy to split them.