Page MenuHomePhabricator

metamta.placeholder-to-recipient doesn't upgrade CCs to To as it says so.
Closed, InvalidPublic

Description

The problem is I created a personal herald rule to send me an email when a certain author commits. The rule passes but the mail delivery fails. When I look at the details under Metadata I see the following

Message PHID PHID-XXXX-xxxxxxxxxxxxxx
Status Details Invalid address: null
Actor XYZ
Related Object rXXxxxxxx: - zzzzzzzzzzzzzzzzzzzzzzzzzzzzzz

To test if empty "metamta.placeholder-to-recipient" is causing the problem I added some email ID to it and resent (using ./bin/mail resend) the mail, it works perfectly, the mail is sent.

Now my question is shouldn't the CC's be upgraded to To here ?

These are the version details

phabricator 77d543ba44638a2e43e1b6bb7f75db80b4046409 (Sat, May 21)
arcanist 0249f90a9a4aa42da0823673a6ac8c620251d82a (Sat, May 21)
phutil 7ff4bd8dfb0b58686a72821dd0e9e79e0f5cbbb9 (Sat, May 21)
Local Version Bitnami Phabricator 20160523-0

Any pointers will be helpful.

Thanks,
Vivekanand.

Event Timeline

epriestley closed this task as Invalid.Jun 10 2016, 3:53 PM
epriestley added a subscriber: epriestley.

This report does not include reproduction instructions. Bug reports must include complete reproduction instructions. See Providing Reproduction Steps.

In any case, I can't reproduce this by making a reasonable effort to guess what the reproduction steps might be. This install is configured with no metamta.placeholder-to-recipient:

However, it upgrades "Cc" to "To" as expected:

Local Version Bitnami

We do not support Bitnami's distribution of Phabricator. See Contributing Bug Reports. Contact Bitnami for support.

There may be a problem here, but we can't move forward with this report. Feel free to file a new report which follows all of the rules laid out in Contributing Bug Reports.