Page MenuHomePhabricator

Subproject tasks get orphaned when switching to parent workboard
Closed, ResolvedPublic

Description

We switched from using a subproject workboard, to using the parent project's workboard.

We batch moved the tasks from the subproject to the parent project, and now all of the subtasks are "orphaned"

  • You can't see them on the parent project workboard
  • You can't see them on the subproject workboard

To reproduce

  1. Create a project with a workboard
  2. Create a subproject with a workboard
  3. Add a task to the parent project
  4. Add a custom column on the subproject, move the task to this column from the parent project.
  5. Remove the subproject's tag from the task, and add the parent project's tag
  6. The task will not be visible on either workboard, until you manually resolve it.

Workaround

The only solution I've found so far is to;

  • manually find all tasks that were orphaned, and use the "Move to Workboard" option on each task, and move it to the subproject workboard's "backlog"

Removing and re-adding the parent project does not work.

Version

3849a6999581b5d520016c5a833688475f561fab (June 4th, master)

Event Timeline

jonathanrseawright updated the task description. (Show Details)

This was likely fixed by D16052 (June 5th). Can you reproduce the issue at HEAD?

I will try that now and get back with you

It looks like that fixed it. I just tried it with one task, moving it into a subproject board, and then back out.

Now I just need to get a list of all the orphaned tasks and either update them via SQL or edit the tasks manually. Thanks!

epriestley closed this task as Resolved.Jun 7 2016, 1:38 PM
epriestley claimed this task.

Great, glad things are working now. Thanks for confirming the fix!