Page MenuHomePhabricator

Firefox body scroll fails when dragging tasks
Closed, WontfixPublic

Description

To reproduce:

  • Use Firefox.
  • View a long list of tasks in Maniphest.
  • Drag a task to the bottom or top of the screen.

In browsers other than Firefox, this causes the screen to scroll. In Firefox, it does not.

Event Timeline

(Specifically, the scrolling is a feature which I added in D10188 but punted on making work in Firefox.)

epriestley moved this task from Backlog to Far Future on the Workboards board.Feb 7 2016, 4:35 AM

@joshuaspence: Did 'per column scrolling' fix this issue? Asking as I have not experienced this problem in Firefox lately...

I think this is actually for the primary task lists, I just didn't do a good job of describing it. Here are more specific reproduction instructions:

  • In Maniphest (not on a Workboard), run a query for something like "All Tasks, Grouped by Priority, Ordered by Priority".
  • This should make the tasks in the list draggable (they'll show a little handle icon on the left, that looks like four lines stacked on top of one another).
  • In Firefox, while you have enough tasks in the result set to give the page a scrollbar, drag a task to the bottom or top edge of the screen.
  • The page should scroll automatically, but currently does not (at least, for me, locally).

This is very rarely used and only affects Firefox. As far as I know, dragging cards around on workboards is fine in every browser.

epriestley closed this task as Wontfix.Mar 12 2019, 3:14 AM
epriestley claimed this task.
epriestley removed a project: Workboards.

Mooted by D20263, which removes the rarely-used drag functionality from global lists.