Page MenuHomePhabricator

Replace some hsprintf() with phutil_tag()
ClosedPublic

Authored by vrana on Nov 8 2013, 5:56 PM.
Tags
None
Referenced Files
F13818845: D7533.id16991.diff
Fri, Sep 20, 10:33 AM
F13818610: D7533.diff
Fri, Sep 20, 8:53 AM
Unknown Object (File)
Wed, Sep 18, 4:44 AM
Unknown Object (File)
Fri, Sep 6, 4:08 AM
Unknown Object (File)
Tue, Sep 3, 1:21 PM
Unknown Object (File)
Mon, Sep 2, 5:09 AM
Unknown Object (File)
Aug 20 2024, 5:15 AM
Unknown Object (File)
Aug 11 2024, 4:55 PM

Details

Reviewers
epriestley
Commits
Restricted Diffusion Commit
rPaca621e21f9c: Replace some hsprintf() with phutil_tag()
Summary

I just want to make sure that this is the style we want.
It seems less readable to me in some cases.

Test Plan

Looked at DarkConsole with errors.

Diff Detail

Branch
hsprintf
Lint
Lint Passed
Unit
Tests Passed

Event Timeline

src/aphront/console/plugin/DarkConsoleXHProfPlugin.php
47–60

This is untranslatable with current pht().

I think this code (which isn't using standard UI classes) is some of the least-readable with phutil_tag(), which is partly why it's hsprintf() in the first place. The next time DarkConsole gets some design work done we'll probably simplify some of this (e.g., remove inline style attributes), which should make it a bit more readable.