Page MenuHomePhabricator

Marking a comment as done is very slow
Closed, InvalidPublic

Description

When I mark a comment as Done, Phabricator waits for an AJAX call to complete before updating the UI to show a checked box.

Right now, at 10pm when I assume our install is not under heavy load, this AJAX call is consistently taking 10-12s.

Is there some way I can profile the slowness using Multimeter?

Event Timeline

jhurwitz created this task.Jun 12 2015, 5:17 AM
jhurwitz raised the priority of this task from to Needs Triage.
jhurwitz updated the task description. (Show Details)
jhurwitz added projects: Restricted Project, Differential.
jhurwitz added subscribers: jhurwitz, angie.

Let me write up a guide on how to use the performance tools and we can start there.

(I can't reproduce this, don't see any queries missing keys in the query plan, and haven't seen reports from other installs, so this isn't an upstream priority.)

epriestley triaged this task as Low priority.Jun 12 2015, 6:22 PM
jhurwitz closed this task as Invalid.Jun 16 2015, 10:47 PM
jhurwitz claimed this task.

I think this was a fluke. I later discovered that, about 15 minutes before I filed this bug, our database host had gone read-only and we needed to reboot it. This caused transient issues for the rest of the night (eg, none of our phdaemons were running for about an hour until someone kicked them).

This is now consistently taking 500-600ms for me.

I'm going to write this off as being caused by the issues we had that night.

angie moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Jun 17 2015, 5:14 PM
angie reopened this task as Open.Jun 17 2015, 8:25 PM
This comment was removed by angie.
angie moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Jun 17 2015, 8:25 PM
angie closed this task as Invalid.Jun 17 2015, 8:28 PM
angie moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.