Page MenuHomePhabricator

Creating a new task needs option to prompt user for visibility
Closed, ResolvedPublic

Description

We're running a Phabricator instance that has a mix of private and public stuff. It is too easy to post items that are Private as Public and wondering if there's any way to have the visibility option actually prompt you to select an item from the list instead of having it default? Setting this to a private group prevents public users from adding new tasks. So maybe a option to set the default as '-- Select One --' or something similar?

Event Timeline

dkobia created this task.Jul 31 2014, 1:02 PM
dkobia raised the priority of this task from to Needs Triage.
dkobia updated the task description. (Show Details)
dkobia added a project: Phabricator.
dkobia added subscribers: dkobia, shadowhand.
qgil edited projects, added Maniphest; removed Phabricator.Jul 31 2014, 1:23 PM
qgil added a subscriber: qgil.

Our expectation is the T3820 will resolve this in a 'Vanilla Phabricator' kind of way. Separately it might be worth having a "not set" policy option as the default in Applications/Policies.

Actually T3820 resolves our issues with private and public projects. Any thoughts on the timeline for this? I can definitely understand that the task adds all kinds of complexity. The 'not set' policy option is low hanging fruit though so might be worth considering in the interim.

qgil added a comment.Jul 31 2014, 3:39 PM

@dkobia, you may want to have a look at the work in this direction that we are doing for Wikimedia:

It seems to work. We haven't tested it thoroughly yet because we are working on other items before launching our Phabricator instance to real users.

Check this box before proceeding:

  • Yes, I know that I'm totally on my own and I won't sue anybody for any trouble caused by this piece of code.

;)

chad closed this task as Resolved.Nov 1 2014, 4:04 PM
chad claimed this task.

Going to close this, T3820 is our best solution, and in interim there are other options like Herald or writing an EventListener for TYPE_MANIPHEST_DIDEDITTASK