Page MenuHomePhabricator

Can't create one day event
Closed, ResolvedPublic

Description

How to reproduce:

  • Check one day event
  • Set the start date to the same date as the end date, create it. You will get: "End date must be after start date."
  • So you have an event from day1 0:00 till day2 23:59
  • You can now set the end date to day1

Event Timeline

Version infos are:

phabricator
    0d1654446be6de43b2bd12fcc247db0dc1a46464 (Sat, Jun 10) 
arcanist
    c04f141ab0231e593a513356b3832a30f9404627 (Fri, Jun 9) 
phutil
    74a1350416eb2df825c2315d6519bee03f77bee9 (Mon, Jun 5)


Example 1: You can't create an event from day 1 0:00 till day 1 23:59


Example 2: You can change it later if you want, but it is not possible on creation.

I can't reproduce this. Here's what I did:

  • Navigate to Calendar.
  • Click Create Event.
  • Click All Day Event.
  • Save the form.

Here's the form before I submitted it:

Here's the event it created:

Luke081515.2 added a comment.EditedJun 13 2017, 9:09 PM

That's weird since I exactly did the same with my version from above. Did you used the current or my version? Or should I update and try if I can reproduce it at the master?

I used the current version, but there should be no meaningful changes to this behavior between your version and HEAD.

Should not, but looks like there are. I updated to master now, and it works now.

epriestley closed this task as Resolved.Jun 13 2017, 9:21 PM
epriestley claimed this task.

iiam

chad added a comment.Jul 11 2017, 8:40 PM

Why does your date format look different than ours? Is that a local modification or do we support this somewhere I'm not aware of.

Hm, this screenshot made me dig a bit into the whole thing, so here is what I've found:
First, my date format is different because of my settings:

What I experienced now, is weird: I changed my personal settings to the default value (F5042478), which is the european format in my case too (not sure why yet?), and after I changed that, I'm not able to reproduce that issue anymore. Maybe this is just a migration issue, so something went wrong due upgrading from an older version, so it is not reproducible with a fresh install?