Page MenuHomePhabricator

404 when trying to create a new repository
Closed, InvalidPublic

Description

I just setup a new Phabricator cluster and I'm unable to create any repositories. From the /diffusion/edit/ page, I click on "Create a new Git repository" which takes me to /diffusion/edit/?vcs=git, which shows a 404 page.

I was unable to reproduce this on a Phacility box, but I'm still debugging and hope to provide some better reproduction steps momentarily.

Version Information

rP4d2c7e4d3d5d61e34b7e2af3df0e901d89d29433
rPHUd02cc05931b02c684d4c729510090591ca45f951
rARC21fe07925b07cab0f73ec824fe8ce02f53b24fe0

Event Timeline

Possibly related, I'm having issues with Almanac too. I created an Almanac device, but clicking on "Add Interface" takes me to /almanac/interface/edit/?deviceID=2 which shows a 404.

joshuaspence closed this task as Invalid.May 25 2017, 1:17 AM

This was a misconfiguration on my part and I wasn't properly forwarding the query string from nginx to PHP.