Page MenuHomePhabricator

Landing differential from other author does not preserve ownership
Closed, InvalidPublic

Description

I have read T4333 but still don't now why it doesn't work for me.
Situation: A differential D12345 was created by another user, was accepted and is ready to land. He/she doesn't have access rights so i tried landing it:

  • arc patch D12345: The branch with the commit is created. Author is me and date is current (which is already wrong?)
  • arc land--hold : correct detection

This branch has revision 'D12345: bla..." but you are not the author. Land this revision by xyz?

->y
Nothing changes, I'm still author.

With --trace I can see

[39] <exec> $ git commit --author 'Alex...

Ok, author is still me, but why?

Reproducible: always

arc version:

arcanist 224986af634e1dfc40916e5baee76897db4c907f (8 Feb 2017)
libphutil 82f71f62129bc19f28aeed8c660c931e512a66e7 (9 Feb 2017)

I cannot determine the version for phabricator.kde.org because I'm not admin (and I ask myself why version information is restricted)

Event Timeline

abika created this task.Feb 13 2017, 5:41 PM

This is a copy of downstream https://phabricator.kde.org/T5242. See that task for discussion.

abika added a comment.Feb 13 2017, 6:25 PM

Ah, thanks! Good to know what my own community is doing.

However, if there is currently the possibility that a differential can be created without author information arc should handle this case correctly.
A warning message my be appropriate.
But specially asking if the author should be changed if this isn't even possible seems clearly wrong behaviour.

epriestley closed this task as Invalid.Feb 13 2017, 8:45 PM

See downstream for general discussion. See T12256 / T12257 for upstream followups.