Page MenuHomePhabricator

Searching for symbol / filename "PhabricatorProfilePanel" does not list commit when this symbol / file was removed
Closed, WontfixPublic

Description

42896f9f90442ecb53789769206de62beeab720e removed the PhabricatorProfilePanel symbol and also the associated file "PhabricatorProfilePanel.php". However, searching for "PhabricatorProfilePanel" does not not bring up this commit. Instead the search result contains only two items: The deleted documentation, without a hint on what replaced this class, and T10308, which is unrelated to the removal.

I would expect the search to also find things based on the contents of commits (i.e. at least least affected filenames, but actually even the changed text itself).

This was observed on https://secure.phabricator.com/ as of today, 2017-01-03 around 12:00 UTC.

Event Timeline

urzds created this task.Jan 3 2017, 12:04 PM
chad added a subscriber: chad.Jan 3 2017, 3:07 PM

GitHub returns no results as well, which aligns with my expectation. Do you have an example piece of software that does work like this?

urzds added a comment.Jan 4 2017, 11:36 AM

I just tried it on GitHub an see that you're right. I guess this finally shifts this task into the feature request area, for which I would like to present the root cause: What I actually tried to achieve, when searching for for "PhabricatorProfilePanel", was to figure out in which commit this symbol got removed from Phabricator, so as to know how to change my extension's code (T10308#205605) to make it work with current Phabricator.

epriestley closed this task as Wontfix.Jan 4 2017, 2:54 PM
epriestley claimed this task.
epriestley added a subscriber: epriestley.

This is working as intended.

We will begin providing more tailored guidance about compatibility breaks when we formally support third-party application development (see T5447). Were this guidance provided, you could, e.g., open the wiki document listing all the backward compatibility breaks and search it for PhabricatorProfilePanel using your browser. We may also provide other support (for example, leave a setup warning in place to warn you about the name change). Today, we do not provide this guidance, and you should expect no support from us if you choose to modify Phabricator.

Many backward compatibility breaks take a form other than a class name change, so indexing old symbol locations can not represent a comprehensive approach to providing compatibility guidance.