Page MenuHomePhabricator

"Change Subscribers" field does not include subscribers that will be added to a task when a Maniphest comment is submitted
Closed, ResolvedPublic

Description

(I believe we already show any changes that pressing the submit button will make to subscribers accurately in the preview. This wasn't always true prior to EditEngine and I think the preview/actual effect would sometimes disagree in weird cases, but I believe the preview is now always fully accurate. However, it's quite easy to miss.)

I don't see this behavior. Maybe I'm misunderstanding. I've attached a screenshot of what I see.

Event Timeline

Sorry, I was responding primarily to @chad there -- the preview is at the bottom. I've circled what I was talking about here:

epriestley closed this task as Resolved.Aug 22 2016, 7:54 AM
epriestley claimed this task.

I'm going to close this since it's working as intended and was just based on a miscommunication -- the actions UI (above the comment text area) is not expected to show a preview of the effects of a change. Instead, the preview UI (below the comment text area) shows this preview information.

(If the preview UI misrepresents the effects of a change, that's a bug, but it appears to be working properly here, as circled.)