Page MenuHomePhabricator

Permanent failure while executing Task ID <id>
Closed, ResolvedPublic

Description

I'm getting a phd daemon hanging with the following error:

[07-Jul-2016 16:37:15] [2016-07-07 16:37:15] EXCEPTION: (PhutilProxyException) Permanent failure while executing Task ID 2077157. {>} (PhabricatorWorkerPermanentFailureException) Commit "286394" has been deleted: it is no longer reachable from any ref. at [<phabricator>/src/applications/repository/worker/PhabricatorRepositoryCommitParserWorker.php:30]
[07-Jul-2016 16:37:15] arcanist(head=stable, ref.master=9c056c5cc887, ref.stable=f1c45a3323ae), phabricator(head=stable, ref.master=b441e8b81e31, ref.stable=58375fa9e6db), phutil(head=stable, ref.master=c72eb747e706, ref.stable=119e5b12ba06)
[07-Jul-2016 16:37:15]   #0 <#2> PhabricatorRepositoryCommitParserWorker::loadCommit() called at [<phabricator>/src/applications/repository/worker/PhabricatorRepositoryCommitParserWorker.php:43]
[07-Jul-2016 16:37:15]   #1 <#2> PhabricatorRepositoryCommitParserWorker::doWork() called at [<phabricator>/src/infrastructure/daemon/workers/PhabricatorWorker.php:122]
[07-Jul-2016 16:37:15]   #2 <#2> PhabricatorWorker::executeTask() called at [<phabricator>/src/infrastructure/daemon/workers/storage/PhabricatorWorkerActiveTask.php:171]
[07-Jul-2016 16:37:15]   #3 <#2> PhabricatorWorkerActiveTask::executeTask() called at [<phabricator>/src/infrastructure/daemon/workers/PhabricatorTaskmasterDaemon.php:22]
[07-Jul-2016 16:37:15]   #4 PhabricatorTaskmasterDaemon::run() called at [<phutil>/src/daemon/PhutilDaemon.php:184]
[07-Jul-2016 16:37:15]   #5 PhutilDaemon::execute() called at [<phutil>/scripts/daemon/exec/exec_daemon.php:127]

Any thoughts?

Event Timeline

jsturgeon added a subscriber: edibiase.

Correction, not hanging, but continuously re-scheduling that task in the queue (which is slowing up the queue significantly)

Is the commit ID exactly the same each time, or does it change?

(Or likewise with the task ID.)

jsturgeon added a comment.EditedJul 8 2016, 3:25 PM

Task ID is the same - for the record, I canceled the task using phabricator/bin/worker

That's not expected and I can't reproduce it.

You need to provide reproduction steps that we can execute in a clean environment so we can move forward. See Providing Reproduction Steps.

got it.. if I can figure out how, I'll let you know, in the mean time, cancelling the task has kept it from happening again

epriestley closed this task as Resolved.Jul 8 2016, 3:35 PM
epriestley claimed this task.

Sounds like this is resolved for now. Feel free to file a followup report if you are able to identify reproduction steps.