Page MenuHomePhabricator

Owner locked out of project
Closed, ResolvedPublic

Description

We have recently seen a problem with a user who is now locked out of being able to add members or editting the project they created.

The project log for creation looks like this:

s... created this project.Via Web · Aug 10 2015, 1:36 PM
s... added a member: s....
s... changed the visibility from "All Users" to "Subscribers".
s... changed the edit policy from "All Users" to "Subscribers".
s... changed the join policy from "All Users" to "Subscribers".

After this, the user was able to add members and edit without problems. More recently, however, the user is no longer able to add members or edit the project anymore. I notice it is also no longer possible to set visibility, etc. to Subscribers, so I wonder whether we've run into some bug caused by changes in policy groups/user rights.

More importantly, though: any way for us to return control of the project back to the owner?

Event Timeline

Subscribers were removed from projects, so this policy no longer functions.

You can use bin/policy unlock to open the project back up (this will set the policies permissively), then edit it to restrict it appropriately.

Awesome. That worked, thanks.

9999999999 added a mock: Restricted Pholio Mock.Feb 26 2016, 1:07 PM
epriestley removed a mock: Restricted Pholio Mock.Feb 26 2016, 1:55 PM
epriestley closed this task as Resolved.Feb 26 2016, 2:06 PM
epriestley claimed this task.