Page MenuHomePhabricator

Diffusion diff show source code on diff title bar.
Closed, InvalidPublic

Description

It show the source code protected function buildQueryFromParameters(array $map) { on the diff title bar.

for example : https://secure.phabricator.com/rP73bab571607382a33eb2415e9a24e1ec15166829

Event Timeline

seungrye updated the task description. (Show Details)
epriestley closed this task as Invalid.Feb 17 2016, 12:31 AM
epriestley added a subscriber: epriestley.

This is a feature, not a bug.

It is showing the context for lines 32, 33, and 34 (they are part of the method buildQueryFromParameters(). This is very similar to the feature in Git which does the same thing:

$ git show 73bab
...
--- a/src/applications/conduit/query/PhabricatorConduitLogSearchEngine.php
+++ b/src/applications/conduit/query/PhabricatorConduitLogSearchEngine.php
@@ -37,7 +37,7 @@ final class PhabricatorConduitLogSearchEngine
...

Note the additional context shown on the @@ line.

Our algorithm is not quite the same as Git's, so we don't choose the same context to show, but the intent of both features is similar and this is working as intended.

got it. thanks