Ref T8726. I want to modularize values and reduce how hard-coded / copypasta'd they are.
- Rename get...StandardCondition() to get...StandardType(), since we can drive both conditions and values from it.
- Rename STANDARD_LIST to STANDARD_PHID_LIST for consistency: all "lists" are lists of PHIDs.
- For all standard types which don't require typehaeads, lift their logic into the base class.
- I'll lift typeaheads soon, but need to generalize them first.